Package Details: icestorm-git r788.83b8ef9-2

Git Clone URL: https://aur.archlinux.org/icestorm-git.git (read-only, click to copy)
Package Base: icestorm-git
Description: Lattice iCE40 FPGAs Bitstream Documentation (Reverse Engineered)
Upstream URL: https://github.com/YosysHQ/icestorm
Licenses: ISC
Conflicts: icestorm
Provides: icestorm
Submitter: sebo
Maintainer: FabioLolix
Last Packager: FabioLolix
Votes: 19
Popularity: 0.000823
First Submitted: 2015-10-05 16:00 (UTC)
Last Updated: 2021-12-22 10:25 (UTC)

Latest Comments

TomKeddie commented on 2017-05-07 03:05 (UTC)

I just built and installed this ok on a Raspberry pi. -arch=('x86_64') +arch=('x86_64' 'armv6h') Linux alarmpi 4.9.25-2-ARCH #1 SMP Fri May 5 00:45:06 UTC 2017 armv6l GNU/Linux Cheers, Tom

sebo commented on 2017-05-03 16:36 (UTC)

Unless I am mistaken, ARM is not supported by Arch Linux, only a similairly named, but different distrubution. I could however add 32 bit x86 as supported, if someone could test it.

benallard commented on 2017-04-29 12:45 (UTC)

Is there a reason to limit the architecture to x86_64 ? the software builds fine on arm for instance.

sebo commented on 2015-12-30 20:07 (UTC)

Thanks FSMaxB, I was not aware of libftdi-compat. The dependency has now changed from libftdi to libftdi-compat. Removing the libftdi dependency might allow you to uninstall libftdi and its dependency confuse. Also, the version was bumped.

FSMaxB commented on 2015-12-30 18:56 (UTC)

Please replace libftdi with libftdi-compat, this will also make the CFLAGS and LDLIBS hack unnecessary!

sebo commented on 2015-12-18 15:41 (UTC)

Thank you cyrozap, patch has been applied.

cyrozap commented on 2015-12-18 05:10 (UTC)

This patch correctly sets the license to "custom:ISC", adds a license file (the README) into /usr/share/licenses/icestorm-git, and updates the pkgver: https://paste.fedoraproject.org/302577/45041523/