Package Details: icewm2 1.4.2-5

Git Clone URL: https://aur.archlinux.org/icewm2.git (read-only)
Package Base: icewm2
Description: A window manager designed for speed, usability and consitency (enhanced)
Upstream URL: http://github.com/bbidulock/icewm
Keywords: floating windowmanager X11
Licenses: LGPL
Conflicts: icewm
Provides: icewm
Replaces: icewm
Submitter: bidulock
Maintainer: bidulock
Last Packager: bidulock
Votes: 7
Popularity: 0.770019
First Submitted: 2014-09-01 11:01
Last Updated: 2017-08-15 06:40

Latest Comments

dreieck commented on 2018-01-30 14:02

@bidulock:

pkgver might matter for other packages depending on icewm and needing a specific version, a specific minimal version or a specific maximal version. Dependency checks will fail if a dependency on icewm includes some version number but none is provided.

Regading the fribidi issue: OK, I see. I solved it for myself with a customizepkg-hook. There might be an if-clause in the PKGBUILD that adds the dependency if fribidi is found in the build environment.

bidulock commented on 2018-01-28 23:22

@dreieck, fribidi is not needed. But, icewm will build against it if it is there. Try building in a clean chroot and you will see that fribidi is not necessary.

pkgver doesn't matter either: there was no release of icewm beyond 1.3.8 that was not on the fork.

dreieck commented on 2018-01-28 11:12

Can you change

provides=($_realname)

to

provides=("${_realname}=${pkgver}")

i.e. adding the $pkgver to what is provided?

Note: Some packages might check for the version of packages they depend on.

dreieck commented on 2018-01-28 10:10

When checking with namcap, I get the issue

icewm2 E: Dependency fribidi detected and not included (libraries ['usr/lib/libfribidi.so.0'] needed in files ['usr/bin/icehelp', 'usr/bin/icewmtray', 'usr/bin/icewm', 'usr/bin/icewmbg'])

so, 'fribidi' needs to be added to the depends-array.

bidulock commented on 2016-01-08 17:55

This package is for releases only. icewm-git builds from git.

Borderliner commented on 2016-01-08 17:24

What's the difference between this package and icewm-git?