Package Details: ignition-common-3 3.14.1-1

Git Clone URL: https://aur.archlinux.org/ignition-common-3.git (read-only, click to copy)
Package Base: ignition-common-3
Description: A collection of useful classes and functions for handling many command tasks. This includes parsing 3D mesh files, managing console output, and using PID controllers.
Upstream URL: https://gazebosim.org/libs/common
Licenses: Apache
Provides: ignition-common
Submitter: Homalozoa
Maintainer: acxz
Last Packager: acxz
Votes: 1
Popularity: 0.003787
First Submitted: 2021-04-19 07:09 (UTC)
Last Updated: 2022-06-14 20:14 (UTC)

Pinned Comments

acxz commented on 2022-05-10 04:08 (UTC)

Development is on Github: https://github.com/acxz/gazebo-arch Please open issues and PRs there instead of commenting.

Latest Comments

acxz commented on 2022-05-10 04:08 (UTC)

Development is on Github: https://github.com/acxz/gazebo-arch Please open issues and PRs there instead of commenting.

oljik commented on 2022-03-25 18:05 (UTC)

there is a commit in git which we can use to patch for ffmpeg5 compatibility

Homalozoa commented on 2022-03-04 14:55 (UTC)

@billypilgrim Good idea! Thank you!

billypilgrim commented on 2022-03-04 10:41 (UTC)

@Homalozoa: You should be able to build with ffmpeg4.4 by adding this line to the PKGBUILD: export PKG_CONFIG_PATH=/usr/lib/ffmpeg4.4/pkgconfig

bobosito commented on 2022-02-27 15:06 (UTC)

Have you installed x264?

KenwoodFox commented on 2022-02-23 20:19 (UTC)

Im getting issues building due to

error: could not find all required packages:
    libx264.so=164-64 (target)

It would be a real pain to uninstall my system ffmpeg and break everything that depends on it, is there another way?

Homalozoa commented on 2022-02-22 04:16 (UTC)

Unfortunately not. Hince you have to remove ffmpeg before building this package.

bobosito commented on 2022-02-21 17:04 (UTC)

Are ffmpeg and ffmpeg4.4 supposed to conflict with each other?

Homalozoa commented on 2022-02-21 15:04 (UTC)

Due to the issue-306, I changed the depend ffmpeg to ffmpeg4.4, but they are not conflict each other. Please build this package without ffmpeg in your environment.

Homalozoa commented on 2022-02-21 13:57 (UTC)

@acxz Thanks for your help. I've fixed it.

bobosito commented on 2022-02-20 21:23 (UTC)

Just removing the line with the conflicts statement fixes the package build for me.

acxz commented on 2022-02-11 03:55 (UTC) (edited on 2022-02-16 00:45 (UTC) by acxz)

@Homalozoa I believe conflicts should not have the empty quotes. I am getting the following error: ==> ERROR: conflicts is not allowed to be empty.

Also when updating the PKGBUILD, you should update the .SRCINFO and the pkgrel so that the update is propagated to the AUR database.

acxz commented on 2022-01-25 22:50 (UTC)

However, adding the conflicts line means that gazebo and ign-gazebo cannot be installed together. The way ignition packages are installed allow them to be installed to versioned directories so the conflicts is not at all needed.

@Homalozoa, if you could empty the contents of the conflicts that would be much appreciated.

acxz commented on 2022-01-25 22:48 (UTC)

Thx for the suggestion @billypilgrim. Having the provides is definitely needed for this package.

Thx for adding it @Homalozoa!

billypilgrim commented on 2021-05-18 09:29 (UTC) (edited on 2021-05-18 09:29 (UTC) by billypilgrim)

Thanks for packaging this!

There is a problem that some other AUR packages depend on ignition-common>=3, which this package doesn't currently satisfy, so you can get build errors.

You can fix this by adding this to the PKGBUILD:

provides=("ignition-common=$pkgver")
conflicts=("ignition-common")