Package Details: imagemagick-no-hdri 7.1.0.34-1

Git Clone URL: https://aur.archlinux.org/imagemagick-no-hdri.git (read-only, click to copy)
Package Base: imagemagick-no-hdri
Description: An image viewing/manipulation program
Upstream URL: https://www.imagemagick.org/
Licenses: custom
Conflicts: imagemagick, imagemagick6, libmagick, libmagick6
Provides: imagemagick, libmagick
Submitter: mehcode
Maintainer: MarsSeed
Last Packager: MarsSeed
Votes: 23
Popularity: 0.000000
First Submitted: 2013-09-16 22:02 (UTC)
Last Updated: 2022-05-15 18:05 (UTC)

Required by (1063)

Sources (3)

Latest Comments

Kubax commented on 2022-01-31 22:36 (UTC)

@MarsSeed: (or anyone else) feel free to takeover the package, i don't use it anymore.

MarsSeed commented on 2022-01-31 22:30 (UTC)

For even more resource-saving, I suggest to build this with:

./configure --with-quantum-depth=8 --disable-hdri

(Source: https://github.com/ImageMagick/ImageMagick#news )

I think if one doesn't need HDR, they also don't need 16 bits per channel.

Memory consumption will be 1/4th of default ImageMagick with this config.

Kubax commented on 2020-06-12 07:06 (UTC)

updated to Version 7.0.10-18

only build the version and updated here, did not test it. (I don't have the time at the moment)

Please report back if there are problems.

Kubax commented on 2017-03-01 13:42 (UTC)

updated to latest version. complete rebuild on ABS Version. Also doesn't need libcl anymore (from ABS).

tokland commented on 2017-02-03 10:41 (UTC)

Source link not working for me, had to use https://ftp.osuosl.org/pub/blfs/conglomeration/ImageMagick/

cedric.brancourt commented on 2015-08-29 10:00 (UTC)

PKGBUILD has been updated at https://github.com/Electron-libre/imagemagick-no-hdri for 6.9.2

kdiogenes commented on 2015-03-30 15:54 (UTC)

The source url pointed by evilgnome isn't working anymore, try this: http://ftp.lfs-matrix.net/pub/blfs/conglomeration/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz

sajinmp commented on 2015-03-21 19:06 (UTC)

you just got to change the version number in the pkgbuild and it works.

cedric.brancourt commented on 2015-02-18 09:14 (UTC)

Sorry I've been busy and this package need a light refactoring. sources are on github https://github.com/Electron-libre/imagemagick-no-hdri I encourage anyone to fork and submit pull request for version upgrade. If package get outdated you can : - Fork - Update version and checksum - mkaurball - then upload package to AUR. Since I am not using it anymore I will not be the best person to keep it up to date.

andykluger commented on 2015-02-17 22:07 (UTC)

Aside from the version being out of date, the source url does not work for me right now. I notice the imagemagick pkgbuild used for the offical Arch repo uses ftp://ftp.sunet.se/pub/multimedia/graphics/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz

commented on 2015-02-07 04:14 (UTC)

Outdated pkgver=6.9.0.4 sha1sums=('5a45acbdb3b2b46151ad0689a9903940773215ea')

commented on 2015-02-07 02:52 (UTC)

Outdated pkgver=6.9.0.4 md5sums=('89e278be06d8eb8e8bd6be2c8a13ab2b') sha1sums=('5a45acbdb3b2b46151ad0689a9903940773215ea')

akhramov commented on 2015-01-20 09:27 (UTC)

Outdated pkgver=6.9.0.3 sha1sums=('c7bb4eebef59544d0411ed56bda64f34fafb11f3')

PhilThompson commented on 2014-11-24 00:58 (UTC)

Out of date again: pkgver=6.9.0.0 sha1sums=('6bf4263ceaeea61e00fe15a95db320d49bcc48c4')

philpirj commented on 2014-10-31 17:57 (UTC)

And update checksum (to 84abbeab6d142267fe6eedfbbfaec11d43075c48)

philpirj commented on 2014-10-31 17:56 (UTC)

Just bump version pkgver=6.8.9.9

supersym commented on 2014-10-29 15:41 (UTC)

link is dead ==> Making package: imagemagick-no-hdri 6.8.9.8-1 (wo okt 29 18:36:54 CET 2014) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Downloading ImageMagick-6.8.9-8.tar.xz... curl: (22) The requested URL returned error: 404 Not Found ==> ERROR: Failure while downloading ImageMagick-6.8.9-8.tar.xz

cedric.brancourt commented on 2014-10-06 08:57 (UTC)

Updated

RazZziel commented on 2014-10-05 10:18 (UTC)

Fails to build: ==> ERROR: Failure while downloading ImageMagick-6.8.9-7.tar.xz Aborting...

cedric.brancourt commented on 2014-08-27 06:56 (UTC)

Updated to 6.8.9.7

cedric.brancourt commented on 2014-08-04 16:22 (UTC)

I've made a new version of the PKGBUILD see my blog post for install instruction : http://through-voidness.blogspot.fr/2014/08/rmagick-and-archlinux-imagemagick-hdri.html

tr9sh commented on 2014-08-04 07:48 (UTC)

Fixed my troubles by removing the patch and updating the version to 6.8.9.6.

tr9sh commented on 2014-08-01 12:16 (UTC)

Any idea on howto fix[0][1]? Seems that the API libjpeg2 API broke on a newer version. [0]: http://pastebin.com/KthHnq4t [1]: http://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=25416

drbig commented on 2014-05-18 07:43 (UTC)

Scratch the below --with-perl-options silliness. It's perlbrew's evil doing. To fix: remove loading of any perlbrew crap from .bashrc or equivalent and start a shell with fresh env (e.g. bash -l) and then check output of perl '-V:install.*'. It should point to the default perl. After that makepkg should build everything as intended.

drbig commented on 2014-05-18 07:24 (UTC)

This may be due to me having perlbrew, though I did clean $PATH before makepkg: With --with-perl-options="INSTALLDIRS=vendor" the perl crap get's installed at /, which not only makes it unusable, it's also sacrilege. The obvious fix is to change that option to --with-perl-options="PREFIX=/usr/lib/perl5/vendor_perl" (which I assume the magic INSTALLDIRS=vendor was supposed to do). Also, not related to the above, is the concern whether to provide symlinks for HDRI enabled libraries - I know it's a dirty hack, but some software needs the HDRI version (e.g. Emacs) and some can't stand the HDRI version (e.g. ruby's rmagick) - and I absolutely don't care about HDRI. Or better make it somehow that both HDRI and non HDRI version can coexist peacefully.

itlodge commented on 2014-04-04 03:08 (UTC)

I think the source link should be "http://ftp.sunet.se/pub/multimedia/graphics/ImageMagick/" instead of "ftp://ftp.sunet.se/pub/multimedia/graphics/ImageMagick/". In some university, including mine, it's not allowed to for "ftp".

axil42 commented on 2014-03-18 20:11 (UTC)

@Noctua The packages you mentioned are included in base-devel which is implied and not needed in makedepends. https://wiki.archlinux.org/index.php/Arch_User_Repository#Getting_started

commented on 2014-01-29 12:53 (UTC)

You may want to add automake and autoconf to the makedependencies. I for one needed to install them before this would work.

dbldub commented on 2014-01-13 22:22 (UTC)

I was able to install the newest version on the FTP site from 1/12/2014 by updating the version and sha1sum in PKGBUILD. #update pkgver pkgver=6.8.8.2 #update first line of sha1sum sha1sums=('dc51b9d77f69bec96f398a557acb531c5af13fbc' 'e143cf9d530fabf3b58023899b5cc544ba93daec')