Package Details: imgmin-git 1.1.r17.g3451031-7

Git Clone URL: https://aur.archlinux.org/imgmin-git.git (read-only, click to copy)
Package Base: imgmin-git
Description: Automated lossy JPEG optimization
Upstream URL: https://github.com/rflynn/imgmin
Licenses: MIT
Conflicts: imgmin
Provides: imgmin
Submitter: Magotchi
Maintainer: Magotchi
Last Packager: Magotchi
Votes: 3
Popularity: 0.000000
First Submitted: 2015-08-14 15:20
Last Updated: 2020-03-28 15:04

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

sekret commented on 2020-03-28 22:45

Well done, workd perfectly now :-)

Magotchi commented on 2020-03-28 15:04

sekret: Please let me know if it's now working in your chroot build.

Magotchi commented on 2020-03-27 22:31

I'm away from my computer, but I believe it should be "pkg-config" instead of "MagickWand-config" on line 31.

sekret commented on 2020-03-27 21:24

Something's wrong with the prepare function. The package builds fine with makepkg, but fails with makechrootpkg in a clean chroot (which I prefer to use), but I don't understand why. Maybe you have an idea?

Here's the end of the output: http://ix.io/2fHi

Magotchi commented on 2020-03-27 15:49

An upstream change in MagickWand-config from ImageMagick 7 broke this build a few days ago, but I've now fixed it.

Magotchi commented on 2017-01-03 20:47

Somebody flagged this out-of-date. I unflagged it because the PKGBUILD builds the current Git version of the software (currently commit 3451031f). If I'm misunderstanding something, please let me know.

Magotchi commented on 2016-02-11 15:39

Sorry for the delay. I've added them.

sekret commented on 2016-02-05 22:39

Could you please add 'armv7h' to the arch line? It builds just fine on my Raspberry Pi 2 :)

Most probably it builds just fine for armv6h too (e.g. Raspberry Pi 1), but I cannot confirm...

Magotchi commented on 2015-08-24 17:02

I submitted an issue upstream (Quality Worse than with ImageMagick convert): https://github.com/rflynn/imgmin/issues/56

I also found and sent a fix for the problem, and I temporarily made the fix with a sed one-liner in this PKGBUILD.

Magotchi commented on 2015-08-23 20:20

I updated the PKGBUILD to your version. Thanks.