Package Details: include-what-you-use 1:0.9-2

Git Clone URL: https://aur.archlinux.org/include-what-you-use.git (read-only)
Package Base: include-what-you-use
Description: A tool for use with clang to analyze #includes in C and C++ source files
Upstream URL: http://include-what-you-use.org
Licenses: LLVM Release License
Submitter: Mindless
Maintainer: sebschrader
Last Packager: sebschrader
Votes: 18
Popularity: 0.708557
First Submitted: 2011-12-03 05:58
Last Updated: 2018-02-24 00:32

Latest Comments

sebschrader commented on 2018-02-24 00:34

I had to change line 31 that reads

Sorry, I dropped thank chunk during a git rebase.

Tristero commented on 2018-02-23 16:34

I had to change line 31 that reads

cd $srcdir/$pkgname/build

to

cd "$srcdir/$pkgname-clang_${_clang_ver}/"build

then package() worked

sebschrader commented on 2018-02-22 21:21

Upstream didn't post a release on their website but a release on GitHub.

See this GitHub issue: https://github.com/include-what-you-use/include-what-you-use/issues/462

marmistrz commented on 2017-07-06 10:01

@mmlb, and the very issue says that:

> In the meantime, I've been using current master with llvm 4.0 and it "seems" to be working ;)

Isn't it just the problem with the prebuilt binaries?

mmlb commented on 2017-04-24 21:41

@johnchen902, iwyu is very much tied to a specific version of clang/llvm. You can track llvm 4.0 release status here https://github.com/include-what-you-use/include-what-you-use/issues/397.

johnchen902 commented on 2017-04-21 03:39

Current clang version is 4.0.0-1

tegularius commented on 2016-09-06 21:21

makedepends should include cmake

mmlb commented on 2015-12-28 05:05

@Svenstaro that was by design since the previous version of IWYU is incompatible with 3.7. I just updated to latest released version that works with 3.7.

Svenstaro commented on 2015-09-29 05:42

This conflicts with llvm 3.7.0 in Arch because 3.7 is < 3.7.0.

mmlb commented on 2015-07-23 13:47

@nerzhul, fixed thanks!

All comments