Package Details: indicator-kdeconnect 1:0.9.1-1

Git Clone URL: https://aur.archlinux.org/indicator-kdeconnect.git (read-only)
Package Base: indicator-kdeconnect
Description: Integrate KDEConnect on desktop environments that use AppIndicators (e.g. Unity)
Upstream URL: https://github.com/bajoja/indicator-kdeconnect
Licenses: GPL
Conflicts: indicator-kdeconnect-git
Submitter: zufallsheld
Maintainer: zufallsheld
Last Packager: zufallsheld
Votes: 13
Popularity: 3.378893
First Submitted: 2017-04-17 21:15
Last Updated: 2017-07-19 19:02

Latest Comments

auscompgeek commented on 2017-07-30 02:47

Here's a fixed PKGBUILD: https://gist.github.com/30dca096b6aab3e4979cdb6c1bb5ed21

In there I've also added some optdepends and changed the build to be out-of-tree.

auscompgeek commented on 2017-07-30 02:17

namcap complains:
- Package should not be arch=(any).
- vala is not a runtime dependency.

Also, the license in the PKGBUILD is wrong.

zufallsheld commented on 2017-07-19 19:02

twa022, you're totally right. I built packages wrong all the time!

Thanks for fixing this.

I'm gonna have to revisit my other packages...

twa022 commented on 2017-07-18 21:16

The PKGBUILD as written builds from the latest git commit not the latest release.
If you add #tag=${pkgver} at the end of the git URI it will checkout that tag. But it's better to just download the tarball unless one isn't available.
Also, building should be in a separate build() function rather than in the package function()
Here's a working PKGBUILD: https://pastebin.com/QAC9Bi8D

zufallsheld commented on 2017-07-16 19:11

@poppinsmac, should be fixed now!

poppinsmac commented on 2017-07-15 18:35

Trying to install I am getting

:: Installing indicator-kdeconnect package(s)...
:: indicator-kdeconnect package(s) failed to install.
:: ensure package version does not mismatch between .SRCINFO and PKGBUILD
:: ensure package name has a VCS suffix if this is a devel package

zufallsheld commented on 2017-04-26 05:19

This version uses the latest tagged release from githhub, the -git version uses the latest commit in the master-branch. So if you want a stable software, use this version.

meltdown commented on 2017-04-26 03:07

Should we be using this one or the -git version?