Package Details: indicator-pastie 0.6.7.5-3

Git Clone URL: https://aur.archlinux.org/indicator-pastie.git (read-only)
Package Base: indicator-pastie
Description: GTK clipboard manager compatible with indicators.
Upstream URL: https://launchpad.net/pastie
Licenses: GPL
Submitter: Madek
Maintainer: prurigro
Last Packager: prurigro
Votes: 4
Popularity: 0.000000
First Submitted: 2010-11-09 15:22
Last Updated: 2015-06-10 04:40

Latest Comments

prurigro commented on 2015-04-22 12:30

@M3t0r: Thanks for the tip- I've added the deps to the package. That said, I can't actually test this one anymore as the indicator-application dependency depends on libappindicator3, which doesn't appear to be a package anymore. Any tips on getting this running again?

Cheers

M3t0r commented on 2015-04-08 00:28

missing dependencies: python2-{gnomevfs,gconf}

prurigro commented on 2014-07-09 22:11

I noticed that https://github.com/fmoralesc/pastie is by the same author and seems to have more up to date code, but it also doesn't appear to have all the expected files when it goes to install itself, so I'm not switching to this source as of yet. That said, if anyone knows what's up and how to get it to build/install happily, maybe it would be worth switching?

prurigro commented on 2014-07-09 22:00

I've adopted this package and made a few updates:
* changed to the new link posted by @na12
* cleaned up the PKGBUILD to comply with namcap
* fixed the dependency list

If anyone notices anything else that should be fixed, let me know!

dcelasun commented on 2011-11-11 09:41

I'm no longer interested in this package. If anyone wants to take over, please say so.

na12 commented on 2011-03-13 12:26

Sorry,it was mistake,that PKGBUILD was intended for indicator-application.Yesterday I was trying to install this package,and I had to change several PKGBUILD's to install pastie that work.
Also you need to change download link to https://launchpad.net/~hel-sheep/+archive/pastie/+files/pastie_0.6.7.5~ppam1.tar.gz

dcelasun commented on 2011-03-13 12:01

Now we are getting somewhere. You are finally talking about an actual issue, instead of just posting some random PKGBUILD. I don't have an x86_64 system, so I can't comment on that but if python-appindicator is required, that still requires merely an additional dependency. It certainly doesn't warrant a different PKGBUILD, which I see you've deleted.

na12 commented on 2011-03-13 11:47

Did you tried to install it on x86_64 system without installing python-appindicator,if you do that and you can start pastie then I am just spamming and ignore this.

dcelasun commented on 2011-03-13 10:45

@na12: Now I'm convinced you are just spamming. Both this package and indicator-application are quite up-to-date and stable. Please provide a reasoning for your PKGBUILDs (e.g why they are better) or stop spamming!

na12 commented on 2011-03-13 10:43

You need to add python-appindicator as dependencies.

dcelasun commented on 2011-03-13 01:22

@na12: My package is more up-to-date and it's working just fine. Why is your PKGBUILD needed?

na12 commented on 2011-03-12 19:50

Working PKGBUILD

# Maintainer: Gianfranco 'Gianfrix' Micoli <gianfrix.mg@gmail.com>

pkgname=indicator-application
pkgver=0.2.9
pkgrel=1
pkgdesc="A library and indicator to take menus from applications and place them in the panel. (Canonical Ayatana Project)"
arch=('i686' 'x86_64')
url="https://launchpad.net/indicator-application"
license=('GPL')
depends=('libindicator' 'libdbusmenu' 'gtk2' 'python-appindicator')
source=(http://archive.ubuntu.com/ubuntu/pool/main/i/indicator-application/indicator-application_${pkgver}.orig.tar.gz
fix-python-bindings.patch
no-bindings-docs.patch)
md5sums=('e63c8f0570d9debadea0f8d86c33c258'
'e3614d571183db9b751e0ff071fe9ed9'
'afa3b6dbbddb7c43e663a250b6685df5')

build() {
cd "$srcdir"/$pkgname-$pkgver

patch -Np1 -i $srcdir/fix-python-bindings.patch || return 1
patch -Np1 -i $srcdir/no-bindings-docs.patch || return 1

sed -i 's|dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION)|dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION)|' configure.ac
sed -i 's|dbusmenu-gtk >= \$DBUSMENUGTK_REQUIRED_VERSION)|dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION)|' configure

./autogen.sh --prefix=/usr --disable-static --enable-introspection=no || return 1

make || return 1
make DESTDIR="$pkgdir" install || return 1
}

na12 commented on 2011-03-12 18:35

Working PKGBUILD

# Maintainer: Gianfranco 'Gianfrix' Micoli <gianfrix.mg@gmail.com>

pkgname=indicator-application
pkgver=0.2.9
pkgrel=1
pkgdesc="A library and indicator to take menus from applications and place them in the panel. (Canonical Ayatana Project)"
arch=('i686' 'x86_64')
url="https://launchpad.net/indicator-application"
license=('GPL')
depends=('libindicator' 'libdbusmenu' 'gtk2')
source=(http://archive.ubuntu.com/ubuntu/pool/main/i/indicator-application/indicator-application_${pkgver}.orig.tar.gz
fix-python-bindings.patch
no-bindings-docs.patch)
md5sums=('e63c8f0570d9debadea0f8d86c33c258'
'e3614d571183db9b751e0ff071fe9ed9'
'afa3b6dbbddb7c43e663a250b6685df5')

build() {
cd "$srcdir"/$pkgname-$pkgver

patch -Np1 -i $srcdir/fix-python-bindings.patch || return 1
patch -Np1 -i $srcdir/no-bindings-docs.patch || return 1

sed -i 's|dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION)|dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION)|' configure.ac
sed -i 's|dbusmenu-gtk >= \$DBUSMENUGTK_REQUIRED_VERSION)|dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION)|' configure

./autogen.sh --prefix=/usr --disable-static --enable-introspection=no || return 1

make || return 1
make DESTDIR="$pkgdir" install || return 1
}

dcelasun commented on 2011-02-14 19:24

Package adopted and updated. This package now features custom monochrome icon support.

Madek commented on 2010-12-04 01:10

added python-keybinder and python2-gnomevfs to depends
thanks jarryson

jarryson commented on 2010-12-03 19:35

http://aur.pastebin.com/9YPznirW

try this patch, make pastie be able to run without gnomevfs. don't know if there is any problem yet.

so now indicator-pastie should depends on keybinder and gnome2-gconf

jarryson commented on 2010-12-03 19:34

http://aur.pastebin.com/9YPznirW

try this patch, make pastie be able to run without gnomevfs. don't know if there is any problem yet.

jarryson commented on 2010-12-03 19:17

how can you be so sure?

in history.py "import gnomevfs"
in protector.py "import keybinder"
in preferences.py "import gconf"

so the depends shoud contain them all, because without them, pastie won't run.

Traceback (most recent call last):
File "/usr/bin/pastie", line 25, in <module>
import pastielib.protector as protector
File "/usr/lib/python2.7/site-packages/pastielib/protector.py", line 22, in <module>
import keybinder
ImportError: No module named keybinder

Madek commented on 2010-12-03 14:04

indicator-pastie don't depend of any of theese packages

jarryson commented on 2010-12-03 13:02

missing dependencies:
keybinder python2-gnomevfs