Package Details: indicator-sound 12.10.1-5

Git Clone URL: https://aur.archlinux.org/indicator-sound.git (read-only)
Package Base: indicator-sound
Description: A unified sound menu
Upstream URL: https://launchpad.net/indicator-sound
Licenses: GPL
Submitter: Madek
Maintainer: ValHue
Last Packager: ValHue
Votes: 22
Popularity: 0.342047
First Submitted: 2010-11-04 04:40
Last Updated: 2015-06-26 09:10

Latest Comments

alucryd commented on 2015-02-09 11:14

libgee06 is no longer available in [extra], only in AUR. FYI, I'm disowning this indicator and removing it from my repo. May someone who actually cares about broken and outdated canonical indicators pick it up ;)

electricprism commented on 2015-02-09 02:53

error: failed to prepare transaction (could not satisfy dependencies)
:: indicator-sound: requires libgee06

clerafel commented on 2014-06-30 00:42

hello, this packet no exist: http://pkgbuild.com/~bgyorgy/sources/indicator-sound-translations-20130310.tar.gz. impossible install

Chazza commented on 2014-04-14 16:00

Added regular ido as dep because ido-bzr is currently broken.

alucryd commented on 2013-10-14 12:35

I'll be renaming libindicator3 to libindicator-gtk3. Even if Ubuntu uses that name, it is just confusing, and a number at the end usually indicates a different package version on arch.

hannibal_l commented on 2013-08-28 10:14

Trying to compile but getting this error
'g_type_init' is deprecated (declared at /usr/include/glib-2.0/gobject/gtype.h:669) [-Wdeprecated-declarations]

What should I do, please?

Anonymous comment on 2013-01-28 19:28

gnome-control-center works better than xfce-mixer easy to change devices, but on another note don't really need to install all that. How does xubuntu get the indicator to launch pavucontrol, because thats how there's works

Anonymous comment on 2013-01-28 16:22

@City-busz thanks that explains it, I've just been trying to set the panel up like xubuntu, almost there :p

City-busz commented on 2013-01-28 12:05

haVok: It doesn't launch pavucontrol, it's normal. Instead it launch gnome-control-center sound settings or xfce4-mixer, if you select sound settings from the menu.

Anonymous comment on 2013-01-28 05:43

I'm running xfce and have xfce-indicator-plugin installed along with indicator-sound and gtk2 version + the indicator-application indicator-application-gtk2. The sound volume control shows up and works but cant figure out how to get it to launch pavucontrol not sure if i'm missing somthing so any help is appreciated.

Xaero252 commented on 2012-11-07 13:22

This appears to no longer build as of recent :(

transport-widget.c:1852:7: error: 'gtk_style_context_notify_state_change' is deprecated (declared at /usr/include/gtk-3.0/gtk/gtkstylecontext.h:843) [-Werror=deprecated-declarations]
CC indicator_sound_service-sound-state.o
cc1: all warnings being treated as errors
make[3]: *** [libsoundmenu_la-transport-widget.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/tmp/yaourt-tmp-xaero/aur-indicator-sound/src/indicator-sound-0.8.5.0/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/tmp/yaourt-tmp-xaero/aur-indicator-sound/src/indicator-sound-0.8.5.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/yaourt-tmp-xaero/aur-indicator-sound/src/indicator-sound-0.8.5.0'
make: *** [all] Error 2

Anonymous comment on 2011-04-16 15:08

I get a configure error... :-(
Don't see where I can find the dbusmenu-gtk package...


configure: error: Package requirements (gtk+-2.0 >= 2.12
indicator >= 0.3.6
dbusmenu-gtk >= 0.2.2
libido-0.1 >= 0.1.11) were not met:

No package 'dbusmenu-gtk' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables APPLET_CFLAGS
and APPLET_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

City-busz commented on 2011-02-13 12:41

The version 0.5.0.1 is the latest stable release of indicator-sound, which is available in Ubuntu Maverick. Newer versions are in development for the upcoming Ubuntu Natty. To compile these package, you have to use the following package versions:
libdbusmenu 0.3.16
libindicator 0.3.14
libindicate 0.4.4

If you really want the latest version, you can use the PKGBUILD from here:
https://github.com/City-busz/Arch-Linux-Repository/tree/master/ubuntu-testing/indicator-sound
The required versions of this package:
libindicator>=0.3.15
libdbusmenu>=0.3.9
vala>=0.11.2

lman commented on 2011-02-13 01:49

I get configure:
error: Package requirements (dbusmenu-glib >= 0.3.1
indicator >= 0.3.6
indicate >= 0.4.1
gee-1.0) were not met:
No package 'indicate' found

but:
aur/libindicate 0.4.93-1 [installed] (52)
A library to raise "flags" on DBus for other components of the desktop to
pick up and visualize. (Canonical Ayatana Project)

Anonymous comment on 2010-12-18 13:58

Updated PKGBUILD:

http://aur.pastebin.com/qfjujeMB

Anonymous comment on 2010-12-16 03:39

indicator-sound_0.5.2-0ubuntu1.diff.gz change for indicator-sound_0.5.2-0ubuntu2.diff.gz

http://aur.pastebin.com/DM5BysD0

Madek commented on 2010-12-04 23:58

ok, momentally change vala by vala-devel
back to vala when vala change to 0.11.2

lafka commented on 2010-12-04 09:54

Could add vala-devel package which provides vala 0.11.2

Madek commented on 2010-11-23 14:04

pkgbuild updates, but it depends on vala 0.11.2, waiting for a vala update

canuckkat commented on 2010-11-22 18:20

Oh, and FYI 0.5.2 needs Vala 0.11.2, which arch hasn't updated to yet.

canuckkat commented on 2010-11-22 18:16

It looks like 0.4.9 disappeared from the pool lol. Latest version appears to be 0.5.2

Madek commented on 2010-11-16 01:37

updated, try again

jens commented on 2010-11-09 00:43

------------------
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for APPLET... yes
checking for PULSEAUDIO... yes
checking for SOUNDSERVICE... no
configure: error: Package requirements (dbusmenu-glib >= 0.3.1
indicator >= 0.3.6
indicate >= 0.4.1
gee-1.0) were not met:

-------------------
Which package do I need to install?

Help appreciated
Thanks

arriagga commented on 2010-11-05 21:02

I did try in many ways but it does not work.
I'll wait for the next built.
thanks for your help.

arriagga commented on 2010-11-05 03:46

i, did it, but still the same error: ((i think its vala releated)
make all-recursive
make[1]: se ingresa al directorio `/tmp/yaourt-tmp-arriaga/aur-indicator-sound/src/indicator-sound-0.4.9'
Making all in src
make[2]: se ingresa al directorio `/tmp/yaourt-tmp-arriaga/aur-indicator-sound/src/indicator-sound-0.4.9/src'
GEN music_bridge_vala.stamp
error: Dbusmenu-Glib-0.2 not found in specified Vala API directories or GObject-Introspection GIR directories
Compilation failed: 1 error(s), 0 warning(s)
make[2]: *** [music_bridge_vala.stamp] Error 1
make[2]: se sale del directorio `/tmp/yaourt-tmp-arriaga/aur-indicator-sound/src/indicator-sound-0.4.9/src'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/tmp/yaourt-tmp-arriaga/aur-indicator-sound/src/indicator-sound-0.4.9'
make: *** [all] Error 2

Madek commented on 2010-11-05 02:04

for me build fine

but, try to add --enable-instrospection=no in the ./configure line
./configure --prefix=/usr --disable-static --enable-instrospection=no || return 1

arriagga commented on 2010-11-05 01:57

i, did it, but still the same error: ((i think its vala releated)
make all-recursive
make[1]: se ingresa al directorio `/tmp/yaourt-tmp-arriaga/aur-indicator-sound/src/indicator-sound-0.4.9'
Making all in src
make[2]: se ingresa al directorio `/tmp/yaourt-tmp-arriaga/aur-indicator-sound/src/indicator-sound-0.4.9/src'
GEN music_bridge_vala.stamp
error: Dbusmenu-Glib-0.2 not found in specified Vala API directories or GObject-Introspection GIR directories
Compilation failed: 1 error(s), 0 warning(s)
make[2]: *** [music_bridge_vala.stamp] Error 1
make[2]: se sale del directorio `/tmp/yaourt-tmp-arriaga/aur-indicator-sound/src/indicator-sound-0.4.9/src'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/tmp/yaourt-tmp-arriaga/aur-indicator-sound/src/indicator-sound-0.4.9'
make: *** [all] Error 2

Madek commented on 2010-11-04 23:44

please install glib2-ubuntu from aur and try again

tell me what your result

arriagga commented on 2010-11-04 22:53

Ok thanks for your fast response.
now I get this error

error: Dbusmenu-Glib-0.2 not found in specified Vala API directories or GObject-Introspection GIR directories
Compilation failed: 1 error(s), 0 warning(s)
make[2]: *** [music_bridge_vala.stamp] Error 1

Madek commented on 2010-11-04 12:15

ohh sorry, i forget it
this depends on ido, but the ido version in aur is outdated
install ido whith this pkgbuild in the bbs https://bbs.archlinux.org/viewtopic.php?pid=848833#p848833

after this install indicator-sound

i update the pkgbuild

arriagga commented on 2010-11-04 11:36

I get this error (also ido does not compile)

configure: error: Package requirements (gtk+-2.0 >= 2.12
indicator >= 0.3.6
dbusmenu-gtk >= 0.2.2
libido-0.1 >= 0.1.11) were not met:

No package 'libido-0.1' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.