Package Details: indimpc-git 20121107-1

Git Clone URL: https://aur.archlinux.org/indimpc-git.git (read-only)
Package Base: indimpc-git
Description: Minimalistic MPD client with support for multimedia keys and notifications
Upstream URL: https://github.com/fmoralesc/indimpc
Licenses: custom
Submitter: grawity
Maintainer: archdria
Last Packager: archdria
Votes: 5
Popularity: 0.000000
First Submitted: 2011-07-07 12:06
Last Updated: 2015-07-15 17:45

Required by (0)

Sources (0)

Latest Comments

jorges commented on 2012-11-06 16:18

I had to modify the PKGBUILD so it builds with recent version of the dependencies. Please consider testing and updating the package.

--- PKGBUILD.ORI 2012-02-02 19:39:58.000000000 -0300
+++ PKGBUILD 2012-11-06 09:24:47.443237539 -0300
@@ -1,14 +1,14 @@
# Maintainer: Mantas M. <grawity@gmail.com>
pkgname=indimpc-git
-pkgver=20120203
+pkgver=20121106
pkgrel=1
pkgdesc="Minimalistic MPD client with support for multimedia keys and notifications"
arch=("any")
url="https://github.com/fmoralesc/indimpc"
license=("custom")
-depends=("dbus-python" "python-notify" "python-mpd")
+depends=("python2-dbus" "python2-notify" "python2-mpd")

jorges commented on 2012-11-06 13:33

I had to modify the PKGBUILD so it builds with recent version of the dependencies. Please consider testing and updating the package.

--- PKGBUILD.ORI 2012-02-02 19:39:58.000000000 -0300
+++ PKGBUILD 2012-11-06 09:24:47.443237539 -0300
@@ -1,14 +1,14 @@
# Maintainer: Mantas M. <grawity@gmail.com>
pkgname=indimpc-git
-pkgver=20120203
+pkgver=20121106
pkgrel=1
pkgdesc="Minimalistic MPD client with support for multimedia keys and notifications"
arch=("any")
url="https://github.com/fmoralesc/indimpc"
license=("custom")
-depends=("dbus-python" "python-notify" "python-mpd")
+depends=("python2-dbus" "python2-notify" "python2-mpd")

archdria commented on 2012-08-28 22:52

You need to place an indimpc.rc file in ~/.config/indimpc with:

[General]
grab_keys = True

[MPD]
host = localhost
port = 6600
password =

[Client]
mode = gnome-terminal
name = ncmpc++
command = ncmpcpp

grawity commented on 2012-08-28 22:17

lahwaacz: Complain to the developer, https://github.com/fmoralesc/indimpc/issues

lahwaacz commented on 2012-08-28 22:08

Please fix this:
Traceback (most recent call last):
File "/usr/bin/indimpc", line 462, in <module>
indimpc = IndiMPDClient()
File "/usr/bin/indimpc", line 267, in __init__
self.grab_mmkeys()
File "/usr/bin/indimpc", line 304, in grab_mmkeys
except ImportError | KeyError:
TypeError: unsupported operand type(s) for |: 'type' and 'type'

fmoralesc commented on 2011-11-05 00:38

I'm requesting the package deletion.

archdria commented on 2011-11-04 23:48

I think this package no longer provides extra features that indimpc or indimpc-git do not, so it should be removed to avoid confusion

Anonymous comment on 2011-07-07 16:03

Could you please add the indimpc.rc file as well? Without it indimpc won't work