Package Details: ingen-git 0.5.1.r2789.f48f9d69-1

Git Clone URL: https://aur.archlinux.org/ingen-git.git (read-only)
Package Base: ingen-git
Description: A modular plugin host for JACK and LV2.
Upstream URL: http://drobilla.net/software/ingen/
Licenses: GPL
Conflicts: ingen
Provides: ingen, ingen=0.5.1
Submitter: skrylar
Maintainer: SpotlightKid
Last Packager: SpotlightKid
Votes: 3
Popularity: 0.000000
First Submitted: 2016-06-27 16:23
Last Updated: 2019-06-16 12:53

Dependencies (12)

Required by (0)

Sources (1)

Pinned Comments

SpotlightKid commented on 2019-06-16 12:48

Important Note: If you get any unresolvable dependencies when trying to install this package, install the *-git packages of serd, sord, lv2, suil, lilv, raul and ganv.

Latest Comments

1 2 Next › Last »

SpotlightKid commented on 2019-06-16 12:48

Important Note: If you get any unresolvable dependencies when trying to install this package, install the *-git packages of serd, sord, lv2, suil, lilv, raul and ganv.

SpotlightKid commented on 2019-06-16 12:25

@stoatally: I've added 'raul=<version>' to the provides list of raul-git. Please re-install raul-git and try installing ingen-git and let me know if that solves the issue for you.

stoatally commented on 2019-06-16 12:05

Installing raul-git doesn't fix the issue:

I have this version installed: raul-git-1:0.8.10.r592.045e70d-1

But on trying to install this package it complains that:

==> Error: Could not find all required packages:
    raul>=0.8.10 (Wanted by: ingen-git)

SpotlightKid commented on 2018-12-19 17:46

@gandalf3: Fixed, thanks!

gandalf3 commented on 2018-12-19 06:35

Seems to be missing a dependency on community/raul

SpotlightKid commented on 2018-08-14 19:10

@tsj: Yes, ingen uses old waf/wscript files for building, which are not compatible with Python 3.7+. I've fixed the PKGBUILD to use python2 instead.

tsj commented on 2018-08-14 18:45

I'm getting the error below when building. Does this look like an upstream bug?

==> Starting build()...
Traceback (most recent call last):
  File "/home/me/.cache/yay/ingen-git/src/ingen/.waf3-2.0.4-0466fbd730f20d94d655ebe324c8478e/waflib/Node.py", line 342, in ant_iter
raise StopIteration
StopIteration

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
  File "/home/me/.cache/yay/ingen-git/src/ingen/.waf3-2.0.4-0466fbd730f20d94d655ebe324c8478e/waflib/Scripting.py", line 118, in waf_entry_point
run_commands()
  File "/home/me/.cache/yay/ingen-git/src/ingen/.waf3-2.0.4-0466fbd730f20d94d655ebe324c8478e/waflib/Scripting.py", line 174, in run_commands
parse_options()
  File "/home/me/.cache/yay/ingen-git/src/ingen/.waf3-2.0.4-0466fbd730f20d94d655ebe324c8478e/waflib/Scripting.py", line 157, in parse_options
ctx.execute()
  File "/home/me/.cache/yay/ingen-git/src/ingen/.waf3-2.0.4-0466fbd730f20d94d655ebe324c8478e/waflib/Options.py", line 198, in execute
super(OptionsContext,self).execute()
  File "/home/me/.cache/yay/ingen-git/src/ingen/.waf3-2.0.4-0466fbd730f20d94d655ebe324c8478e/waflib/Context.py", line 84, in execute
self.recurse([os.path.dirname(g_module.root_path)])
  File "/home/me/.cache/yay/ingen-git/src/ingen/.waf3-2.0.4-0466fbd730f20d94d655ebe324c8478e/waflib/Context.py", line 125, in recurse
user_function(self)
  File "/home/me/.cache/yay/ingen-git/src/ingen/wscript", line 19, in options
ctx.load('compiler_cxx')
  File "/home/me/.cache/yay/ingen-git/src/ingen/.waf3-2.0.4-0466fbd730f20d94d655ebe324c8478e/waflib/Context.py", line 82, in load
fun(self)
  File "/home/me/.cache/yay/ingen-git/src/ingen/.waf3-2.0.4-0466fbd730f20d94d655ebe324c8478e/waflib/Tools/compiler_cxx.py", line 40, in options
opt.load_special_tools('cxx_*.py')
  File "/home/me/.cache/yay/ingen-git/src/ingen/.waf3-2.0.4-0466fbd730f20d94d655ebe324c8478e/waflib/Context.py", line 326, in load_special_tools
lst=self.root.find_node(waf_dir).find_node('waflib/extras').ant_glob(var)
  File "/home/me/.cache/yay/ingen-git/src/ingen/.waf3-2.0.4-0466fbd730f20d94d655ebe324c8478e/waflib/Node.py", line 358, in ant_glob
return list(it)
RuntimeError: generator raised StopIteration

middle0fnowhere commented on 2017-12-19 10:20

@esteband: install lv2-git, that'll give you lv2 >= 1.15.3.

esteband commented on 2017-07-09 14:30

This package won't build for me. It looks like a dependency is listed incorrectly as somewhere as lv2 >= 1.15.3. The most current version of lv2 in the repository is version 1.14.

Cloning into 'ingen-git'...
done.
==> Starting prepare()...
Setting top to : /tmp/yaourt-tmp-stevelx/aur-ingen-git/src/ingen-git
Setting out to : /tmp/yaourt-tmp-stevelx/aur-ingen-git/src/ingen-git/build
Ingen Configuration
Checking for 'g++' (C++ compiler) : /usr/bin/g++
Checking for program 'python' : /usr/bin/python

Global Configuration
Checking for library gcov : yes
* Install prefix : /usr
* Debuggable build : False
* Build documentation : False

Checking for compiler flags ['-std=c++11'] : yes
Checking for header boost/format.hpp : yes
Checking for header boost/intrusive/slist.hpp : yes
Checking for header boost/intrusive_ptr.hpp : yes
Checking for header boost/optional.hpp : yes
Checking for thread_local keyword : yes
Checking for program 'pkg-config' : /usr/bin/pkg-config
Checking for 'lv2' >= 1.15.3 : not found
The configuration failed
(complete log in /tmp/yaourt-tmp-stevelx/aur-ingen-git/src/ingen-git/build/config.log)
==> ERROR: A failure occurred in prepare().
Aborting...
==> ERROR: Makepkg was unable to build ingen-git.
==> Restart building ingen-git ? [y/N]
==> ----------------------------------
==>

skrylar commented on 2016-08-15 03:36

@SAL9000 Cheers.