Package Details: ino 0.3.6-8

Git Clone URL: https://aur.archlinux.org/ino.git (read-only)
Package Base: ino
Description: Command line toolkit for working with Arduino hardware
Upstream URL: http://inotool.org/
Licenses: MIT
Submitter: garyvdm
Maintainer: None
Last Packager: drevilt
Votes: 23
Popularity: 0.000000
First Submitted: 2012-06-22 12:38
Last Updated: 2015-06-08 17:36

Latest Comments

« First ‹ Previous 1 2 3

drevilt commented on 2014-02-23 19:39

does this mean that avrdude is also a dependency ?

enteenteente commented on 2014-02-23 17:33

and while uploading:
$ ino upload
Searching for avrdude.conf ... FAILED
avrdude.conf not found. Searched in following places:
- /usr/local/share/arduino/hardware/tools
- /usr/share/arduino/hardware/tools
- /etc/avrdude


-> avrdude configuration installed with avrdude 6.0.1-3 is in: /etc/avrdude.conf
so you might want to add a symlink /etc/avrdude/avrdude.conf -> /etc/avrdude.conf
or find a bettet solution for this.

thanks!

enteenteente commented on 2014-02-23 17:18

getting:
$ ino
Traceback (most recent call last):
File "/usr/bin/ino", line 3, in <module>
from ino.runner import main
File "/usr/lib/python2.7/site-packages/ino/runner.py", line 23, in <module>
import ino.commands
File "/usr/lib/python2.7/site-packages/ino/commands/__init__.py", line 3, in <module>
from ino.commands.init import Init
File "/usr/lib/python2.7/site-packages/ino/commands/init.py", line 6, in <module>
from configobj import ConfigObj
File "/usr/lib/python2.7/site-packages/configobj.py", line 22, in <module>
import six

installed:
pacman -S python2-six

now:
$ ino
usage: ino [-h] {build,clean,init,list-models,preproc,serial,upload} ...
ino: error: too few arguments

conclusion:
missing dependency python2-six

12qu commented on 2013-09-25 10:21

Version is now at 0.3.6 -- http://pypi.python.org/packages/source/i/ino/ino-0.3.6.tar.gz

Anonymous comment on 2012-12-28 17:58

Hi, python-configobj has been rebuilt as python2-configobj (must edit PKGBUILD).

timthelion commented on 2012-10-17 15:06

OK, so if you increment the version number it works:

# Creator: Gary van der Merwe <garyvdm@gmail.com>
pkgname=ino
pkgver=0.3.4
pkgrel=0
pkgdesc="Command line toolkit for working with Arduino hardware"
arch=(any)
url="http://inotool.org/"
license=('MIT')
depends=('python2' 'python2-pyserial' 'python2-jinja' 'python-configobj' 'arduino')
options=(!emptydirs)
source=(http://pypi.python.org/packages/source/i/${pkgname}/${pkgname}-${pkgver}.tar.gz)

package() {
cd "$srcdir/$pkgname-$pkgver"
python2 setup.py install --root="$pkgdir/" --optimize=1
}
md5sums=('938b4a6762ac585e855a77e0e4f1946a')

# vim:set ts=2 sw=2 et:

timthelion commented on 2012-10-17 14:41

Did you actually test this with the blink sketch? For me it uploads fine but is not blinking(which seems to mean that ino is using the wrong avr libs). Please test this so I can know if this is a specific problem with my system or if this package is broken. (Blink works fine when uploaded through Aruino IDE).