Package Details: input-wacom-dkms 0.42.0-1

Git Clone URL: https://aur.archlinux.org/input-wacom-dkms.git (read-only)
Package Base: input-wacom-dkms
Description: Latest Kernel modules form Wacom tablets (DKMS). Useful if your wacom tablet is not supported upstream yet.
Upstream URL: https://github.com/linuxwacom/input-wacom/wiki/Installing-input-wacom-from-source
Licenses: GPL2
Submitter: apicici
Maintainer: apicici
Last Packager: apicici
Votes: 19
Popularity: 0.018167
First Submitted: 2013-12-06 21:27
Last Updated: 2018-11-01 19:32

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

electricprism commented on 2017-01-17 04:02

Somethings up it won't complete on stock kernel

-----------------------------
Deleting module version: 0.33.0
completely from the DKMS tree.
------------------------------
Done.
(1/1) reinstalling input-wacom-dkms [----------------------] 100%

Creating symlink /var/lib/dkms/input-wacom/0.33.0/source ->
/usr/src/input-wacom-0.33.0

DKMS: add completed.

Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area...(bad exit status: 2)
./configure && make....
Error! Build of wacom.ko failed for: 4.9.4-1-ARCH (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/input-wacom/0.33.0/build/ for more information.

I wonder if this is connected to the update to 0.34
xf86-input-wacom-0.34.0-1-x86_64.pkg.tar.xz

apicici commented on 2017-01-03 15:57

@goldpaw: thank you for letting me know, I fixed it.

goldpaw commented on 2017-01-03 15:25

Seems that the md5sums in the PKGBUILD for build 0.33.0-1 are currently wrong for input-wacom-0.33.0.tar.bz2 from sourceforge and dkms.conf which is included.

==> Validating source files with md5sums...
input-wacom-0.33.0.tar.bz2 ... FAILED
dkms.conf ... FAILED
blacklist-input-wacom-dkms.conf ... Passed

When manually changing them to the correct values in the PKGBUILD, it builds fine. Just wanted to let you know. :)

nishantjr commented on 2016-01-23 14:40

Installing linux-headers fixes post-install failing silently

thermatk commented on 2015-03-25 07:48

0.27 with support for Bamboo Pad is out there, needs update

apicici commented on 2014-02-24 21:29

@mdias: it shouldn't, according to the wiki guidelines

https://wiki.archlinux.org/index.php/Dynamic_Kernel_Module_Support

mdias commented on 2014-02-24 21:23

Should depend on linux-headers

gauteh commented on 2014-01-28 07:43

Yup, works for me! great!

apicici commented on 2014-01-15 15:10

dkms doesn't seem to support compressed modules at all. I circumvented the problem by renaming the new modules and blacklisting the old ones. Let me know if this works for you.

apicici commented on 2014-01-09 08:21

I see. What I can do is to patch the source and have a compressed module built. I'll look into it later today.