Package Details: insomnia 6.5.4-1

Git Clone URL: https://aur.archlinux.org/insomnia.git (read-only)
Package Base: insomnia
Description: HTTP and GraphQL client for developers
Upstream URL: http://insomnia.rest/
Keywords: rest-api
Submitter: marmotz
Maintainer: marmotz (gschier)
Last Packager: gschier
Votes: 59
Popularity: 2.537876
First Submitted: 2016-08-16 09:24
Last Updated: 2019-05-30 19:25

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

gschier commented on 2018-04-26 12:38

Just pushed 15.6.1 and removed that dep. Added because of @pacheco and @stevenroose errors but maybe there's a better way to get it working for them. I don't actually have an Arch install to play with so I'm flying blind here.

victorz commented on 2018-04-26 08:35

Can also confirm Insomnia 5.16.0 works fine without all the lib32 packages. (The source is an amd64 deb, so should work fine.) -15.7 MiB update diff vs 100+ MiB update for me.

Important edit: I don't have the package lib32-gtk2 installed. So that shouldn't be needed.

sQVe commented on 2018-04-26 07:55

One of the major changes in 5.16 is: "Linux builds now include statically linked libcurl (removes libcurl3 dependency)".

@marmotz I think the lib32-gtk2 dependency here is unnecessary. I removed it from the PKGBUILD and the app is still running fine.

thePanz commented on 2018-04-26 06:50

From the new version (Insomnia 5.16.0) I noticed that a huge set of dependencies are installed, namely multilib/lib32-gtk2 and a 37 more packages under the multilib/lib32-* names.

I just edited the PKGBUILD and removed the dependency on lib32-gtk: the installation went ok and the tool is starting correctly.

pacheco commented on 2018-02-02 00:29

Got the same problem reported by @stevenroose.

To fix the dependency issue:

$ sudo pacman -S lib32-gtk2

stevenroose commented on 2018-01-18 10:18

I'm getting

/opt/Insomnia/insomnia.bin: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

I needed the package lib32-gtk2 from the multilib repos.

kvasthval commented on 2017-12-04 12:39

libxss should be added as an dependency. :)

gschier commented on 2017-11-02 22:41

@acidrain42. This is fixed in v5.10.1 :)

acidrain42 commented on 2017-10-31 19:20

I get an error "A libcurl function was given a bad argument (68 MAXREDIRS)" with curl / libcurl-compat 7.56.1-1. Downgrading to 7.56.0-1 fixes the problem.

jonian commented on 2017-05-10 21:42

Hi, insomnia requires gconf as a dependency.

/opt/Insomnia/insomnia.bin: error while loading shared libraries: libgconf-2.so.4: cannot open shared object file: No such file or directory