Package Details: instantreality 2.5.1-1

Git Clone URL: https://aur.archlinux.org/instantreality.git (read-only)
Package Base: instantreality
Description: The framework provides a comprehensive set of features to support classic Virtual Reality (VR) and advanced Augmented Reality (AR) equally well.
Upstream URL: http://www.instantreality.org
Licenses: custom:Fraunhofer-Gesellschaft
Submitter: fho
Maintainer: fho
Last Packager: fho
Votes: 1
Popularity: 0.000365
First Submitted: 2013-01-03 14:53
Last Updated: 2015-07-20 12:01

Required by (0)

Sources (16)

Latest Comments

naraesk commented on 2015-07-20 12:29

Ah okay, thought these tools support aur4 automatically. So, now it is working. Thanks thanks thanks. :)

fho commented on 2015-07-20 12:14

Hmm ... The AUR4 is migrating to something git based. But I think most AUR tools (yaourt,aura,etc) are still accessing the old AUR. I uploaded the package to the old AUR too. Try again please.

naraesk commented on 2015-07-20 12:06

good news, thanks although there is a small problem:

curl: (22) The requested URL returned error: 404 Not Found
==> FEHLER: Fehler beim Download von libtiff5_4.0.3-7ubuntu0.1_amd64.deb

fho commented on 2015-07-20 12:02

Try it. Should be on IR 2.5.1 now.

naraesk commented on 2015-06-30 13:56

Hello again, might it be possible to update to instantreality 2.5.1? :)

I don't know this much about packaging so I can't estimate how huge your effort is, but I appreciate your work very much. =)

fho commented on 2014-08-24 19:58

Oook ... should be fixed now ...

By now I have more or less included half of Ubuntu ...

Problem is that several of the debs are from security.ubuntu.com, which are updated quite frequently. It's a like shooting at a moving target ...

naraesk commented on 2014-08-22 22:40

Still having problems with "aopt", one of the executables of the package.

$ aopt
aopt: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/instantReality/lib/libHermes.so)
aopt: /usr/lib/liblzma.so.5: no version information available (required by /opt/instantReality/lib/libtiff.so.5)
aopt: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/instantReality/lib/libEasySoap.so)
aopt: /usr/lib/libssl.so.1.0.0: no version information available (required by /opt/instantReality/lib/libEasySoap.so)
aopt: /usr/lib/libavformat.so.54: version `LIBAVFORMAT_54' not found (required by /opt/instantReality/lib/libmovie.so)
aopt: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/instantReality/lib/libInstantIO.so)

naraesk commented on 2014-08-05 14:53

Thanks a lot, it's working! :-)

But i had to install bluez-libs and freeglut, they are not listed as dependencies.

fho commented on 2014-08-05 14:39

Released InstantReality 2.4.0 ... no more i686 support from upstream.

naraesk commented on 2014-08-02 14:15

And for current version I get the following error:

(22) The requested URL returned error: 404 Not Found
==> FEHLER: Fehler beim Download von libtiff4_3.9.5-2ubuntu1.5_amd64.deb

naraesk commented on 2014-08-02 13:43

Update to 2.4 would be great!

fho commented on 2013-12-10 10:34

bumped Ubuntu dependencies

fho commented on 2013-10-08 08:40

Ah sorry ... forgot to change one line for the new libtiff version.
Should be fixed ... now :)

cbuehler commented on 2013-10-08 05:19

Thanks for the update, but now I get

==> Starting package()...
install: cannot stat '/home/cbuehler/instantreality/src/libtiff/usr/lib/libtiff.so.4.2.1': No such file or directory

fho commented on 2013-10-07 12:45

Should be fixed now.

cbuehler commented on 2013-10-06 19:37

-> Downloading libtiff4_3.8.2-7ubuntu3.16_amd64.deb...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading libtiff4_3.8.2-7ubuntu3.16_amd64.deb
Aborting..

fho commented on 2013-07-19 13:03

New upstream version.

Running it throws some warnings/errors about libcrypto, I am not sure if that is bad ... but the whole thing is running for now.

fho commented on 2013-05-30 15:49

These are really just missing libraries. Just search for the first part (like libavutil.so.51) on the Ubuntu packages sides ... I really should update this package sometime :)

Anonymous comment on 2013-05-28 18:37

Thank you really much for your fast help.

I changed the links, md5sums and the versions in compile and ln to the newer ones and it installs well.

The program runs but there are several errors and the server can't start.

%sudo /opt/instantReality/bin/InstantPlayer
/opt/instantReality/bin/InstantPlayer: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/instantReality/lib/libInstantIO.so)
/opt/instantReality/bin/InstantPlayer: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/instantReality/lib/libHermes.so)
/opt/instantReality/bin/InstantPlayer: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/instantReality/lib/libEasySoap.so)
/opt/instantReality/bin/InstantPlayer: /usr/lib/libssl.so.1.0.0: no version information available (required by /opt/instantReality/lib/libEasySoap.so)
WebNode listening on 0.0.0.0:39886
libavutil.so.51: cannot open shared object file: No such file or directory
libCg.so: cannot open shared object file: No such file or directory
ERROR: Cannot open server


I already searched for the error messages, but I can't find anything related. Do you have an Idea with that?

fho commented on 2013-05-28 18:00

The libs were updated to version 0.8.6 in the latest precise builds, please try to use the links below.

http://security.ubuntu.com/ubuntu/pool/main/liba/libav/libavcodec53_0.8.6-0ubuntu0.12.04.1_i386.deb
http://security.ubuntu.com/ubuntu/pool/main/liba/libav/libavformat53_0.8.6-0ubuntu0.12.04.1_i386.deb

Anonymous comment on 2013-05-28 17:31

http://security.ubuntu.com/ubuntu/pool/main/liba/libav/libavcodec53_0.8.4-0ubuntu0.12.04.1_i386.deb
http://security.ubuntu.com/ubuntu/pool/main/liba/libav/libavformat53_0.8.4-0ubuntu0.12.04.1_i386.deb

These Dependencies are down and I don't know where to get these :(


I need that program really fast, could anybody help, please?

fho commented on 2013-01-03 14:55

This package relies on several libaries from ubuntu 12.04 as Fraunhofer only releases it in binary form.

I couldn't find any license except for a copyright notice on their side.