Package Details: instawow 1.23.1-1

Git Clone URL: https://aur.archlinux.org/instawow.git (read-only, click to copy)
Package Base: instawow
Description: Package manager for World of Warcraft
Upstream URL: https://github.com/layday/instawow
Keywords: addon warcraft world wow
Licenses: GPL3
Conflicts: python-aiohttp-gns3, python-prompt_toolkit-gns3, python-yarl-gns3
Submitter: Kelaun
Maintainer: layday
Last Packager: layday
Votes: 2
Popularity: 0.040990
First Submitted: 2020-09-10 22:00
Last Updated: 2021-04-04 11:58

Latest Comments

BS86 commented on 2020-12-02 09:01

Made an issue on git: https://github.com/layday/instawow/issues/63

Kelaun commented on 2020-12-02 08:56

Ok in that case you'll need to use instawow through pip for the moment as it is not compatible with aiohttp 3.7.3

Another option I did was add aiohttp to the ignore list of pacman as I have nothing else using it.

Perhaps logging it in git might help as well however I think the dev is using ubuntu.

BS86 commented on 2020-12-02 08:54

that works for letting me install instawow (downgrading python-aiohttp to 3.6.2) but breaks other stuff because other scripts need python-aiohttp in the newest version 3.7.x. Applying Arch updates also gives: error: failed to prepare transaction (could not satisfy dependencies) :: installing python-aiohttp (3.7.3-1) breaks dependency 'python-aiohttp<3.7.0' required by instawow

Meaning installing instawow that way basically breaks Arch updates.

Kelaun commented on 2020-12-02 08:44

Hello BS86, this is due to the upgrade of python to 3.9 on Arch.

What worked for me was the following:

sudo pacman -Rns python-aiohttp-gns3 python-multidict-gns3 python-async-timeout-gns3
yay -S python-loguru
sudo pacman -Rns instawow
yay -S python-aiohttp
yay -S downgrade
sudo downgrade python-aiohttp
yay -S python-aresponses
yay -S instawow

Let me know if this helped.

PS: There is also a new version now where it states those packages as conflicting.

BS86 commented on 2020-12-02 08:37

I am getting those errors upon updating: Package conflicts found: -> Installing python-aiohttp-gns3 will remove: python-aiohttp -> Installing python-multidict-gns3 will remove: python-multidict -> Installing python-async-timeout-gns3 will remove: python-async-timeout -> Conflicting packages will have to be confirmed manually

When resolving those dependencies, the installation fails to satisfy dependencies: ==> Missing dependencies: -> python-aiohttp>=3.1.0

Kelaun commented on 2020-11-04 12:39

@BS86: yes it is as this uses the source from pypi as requested by the developer and this one does not include the GUI. The GUI is only available as a binary on Github directly. I suppose this could be packaged separately though if someone would need it and would be willing to maintain it.

BS86 commented on 2020-11-04 12:36

Is it intentional that the GUI is not present when using this package?

The CLI works fine and is enough, but it would be great to be able to test the GUI ;)