Package Details: intel-npu-driver-bin 1.5.0.20240619_9582784383-2

Git Clone URL: https://aur.archlinux.org/intel-npu-driver-bin.git (read-only, click to copy)
Package Base: intel-npu-driver-bin
Description: Intel(R) NPU (Neural Processing Unit) Driver
Upstream URL: https://github.com/intel/linux-npu-driver
Licenses: MIT
Provides: intel-driver-compiler-npu, intel-fw-npu, intel-level-zero-npu
Submitter: jichi
Maintainer: jichi (songtianlun)
Last Packager: songtianlun
Votes: 3
Popularity: 2.30
First Submitted: 2024-03-25 23:59 (UTC)
Last Updated: 2024-06-21 06:12 (UTC)

Latest Comments

muziknavi commented on 2024-06-21 18:54 (UTC)

There's an error /etc/udev/rules.d/10-intel-npu.rules:1 Invalid key/value pair, ignoring.

It doesn't need escaping quotes in adding rules script.

Also this warning:

Configuration file /etc/udev/rules.d/10-intel-npu.rules is marked executable. Please remove executable permission bits. Proceeding anyway.

jichi commented on 2024-04-24 08:54 (UTC)

It's weird that the new build somehow has a lower version number, but anyway it's now fixed.

songtianlun commented on 2024-04-24 03:36 (UTC)

i get some error in my machine:

$ yay -S intel-npu-driver-bin
AUR Explicit (1): intel-npu-driver-bin-1.4.0.20240322_8393323322-1
:: PKGBUILD 是最新的,跳过下载: intel-npu-driver-bin
  1 intel-npu-driver-bin                     (已安装) (构建文件已存在)
==> 清理哪些软件包的构建文件?
==> [N]没有 [A]全部 [Ab]中止 [I]已安装 [No]未安装 或 (1 2 3, 1-3, ^4)
==> n
  1 intel-npu-driver-bin                     (已安装) (构建文件已存在)
==> 显示哪些包的差异?
==> [N]没有 [A]全部 [Ab]中止 [I]已安装 [No]未安装 或 (1 2 3, 1-3, ^4)
==> n
==> 正在创建软件包:intel-npu-driver-bin 1.4.0.20240322_8393323322-1 (2024年04月24日 星期三 11时32分49秒)
==> 获取源代码...
  -> 正在下载 intel-driver-compiler-npu.deb...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     9    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
curl: (56) The requested URL returned error: 404
==> 错误: 无法下载 https://github.com/intel/linux-npu-driver/releases/download/v1.2.0/intel-driver-compiler-npu_1.4.0.20240322-8393323322_ubuntu22.04_amd64.deb
    正在放弃...
 -> 下载源文件时出错: /home/songtianlun/.cache/yay/intel-npu-driver-bin 
         context: exit status 1 


:: (1/1) 正在解析 SRCINFO: intel-npu-driver-bin
==> 正在创建软件包:intel-npu-driver-bin 1.4.0.20240322_8393323322-1 (2024年04月24日 星期三 11时32分52秒)
==> 正在检查运行时依赖关系...
==> 正在检查编译时依赖关系
==> 获取源代码...
  -> 正在下载 intel-driver-compiler-npu.deb...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     9    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
curl: (56) The requested URL returned error: 404
==> 错误: 无法下载 https://github.com/intel/linux-npu-driver/releases/download/v1.2.0/intel-driver-compiler-npu_1.4.0.20240322-8393323322_ubuntu22.04_amd64.deb
    正在放弃...
 -> 生成时出错: intel-npu-driver-bin-exit status 1
 -> 无法安装以下软件包, 需要手动介入处理:
intel-npu-driver-bin - exit status 1

maybe intel update the version number, make some change can be make it work

git diff PKGBUILD 
diff --git a/PKGBUILD b/PKGBUILD
index 141bf10..ba341b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Jichi Zhang <jichi@1435.es>

 pkgname=intel-npu-driver-bin
-pkgver=1.4.0.20240322_8393323322
+pkgver=1.2.0.20240404_8553879914
 pkgrel=1
 pkgdesc="Intel(R) NPU (Neural Processing Unit) Driver"
 arch=(x86_64)
@@ -39,4 +39,4 @@ package() {

   chown root:root -R "${pkgdir}/"
   chmod 755 -R "${pkgdir}/"
-}
\ No newline at end of file
+}

jichi commented on 2024-04-23 18:36 (UTC)

Version number error, unable to install. Please update or consider adding me for joint maintenance.

Not sure what you mean by "version number error". It installs just fine on my machine.

songtianlun commented on 2024-04-23 01:22 (UTC)

Alright, there is already a similar package available, but there is an issue with the version number that prevents installation. A merge request has been submitted.

@FabioLolix

songtianlun commented on 2024-04-23 01:19 (UTC)

版本号错误,无法安装,请求更新,也可添加我共同维护

Version number error, unable to install. Please update or consider adding me for joint maintenance.

FabioLolix commented on 2024-04-22 15:22 (UTC)

Hello, at the moment this is a disguised -bin pkgbuild and the program is open source, you can both re-upload with -bin suffix and correct this pkgbuild to build from source but this can't stay as it is now