Package Details: intel-opencl 5.0.r63503-2

Git Clone URL: https://aur.archlinux.org/intel-opencl.git (read-only)
Package Base: intel-opencl
Description: Legacy OpenCL(TM) 2.0 Driver for Intel(R) HD, Iris(TM), and Iris(TM) Pro Graphics for Linux (pre-Broadwell)
Upstream URL: https://software.intel.com/en-us/articles/legacy-opencl-drivers#latest_linux_driver
Licenses: custom:intel
Provides: opencl-driver
Submitter: intelfx
Maintainer: None
Last Packager: intelfx
Votes: 26
Popularity: 0.341811
First Submitted: 2016-07-01 01:01
Last Updated: 2019-01-12 05:20

Dependencies (3)

Required by (21)

Sources (1)

Latest Comments

« First ‹ Previous 1 2

Fandekasp commented on 2017-02-22 03:53

@intelfx, can you update the package to r4.0 ?

intelfx commented on 2016-11-12 23:28

@sirocco: sorry, I forgot to regenerate .SRCINFO.

intelfx commented on 2016-11-12 04:57

@archer666: no idea. Works out of the box on my Haswell; I have no other hardware to test.

archer666 commented on 2016-11-05 08:25

Trying this on my Lenovo P50 (P530 GPU) on Arch (4.8.6 kernel) with no luck.

Nvidia is switched off completely (rmmod nvidia, /proc/acpi/bbswitch shows OFF) , /etc/OpenCL/verdors contains

-rw-r--r-- 1 root root 36 Jun 15 10:50 intel-gpu.icd
-rw-r--r-- 1 root root 22 Oct 28 08:18 nvidia.icd

while intel-gpu.icd contains /opt/intel/opencl/libIntelOpenCL.so (which is there)

oclinfo (own) shows nothing, clinfo (amd) dumps core, haven't found any intel tool to check environment in intel-opencl-sdk (other package ofc).

What am I missing?

tonnz commented on 2016-09-02 18:52

This is great news!
Really, i have been trying to get the patch to work on newer kernels for quite
a while now. Maybe i should have just tried running ocl without the patches. Hmm.
Anyways, thanks for putting this up!

intelfx commented on 2016-09-02 18:07

Yes, this OpenCL implementation passes CLBlast unit tests on Haswell i7-4700MQ / Intel HD Graphics 4600 (both the previous version and the one just uploaded, kernel 4.6).

If there are any out-of-tree kernel patches, they must be optional.

tonnz commented on 2016-09-02 12:45

Are you sure this works? According to the installation manual,
this software requires a kernel patch in order to function properly.
And according to Intel, the only supported kernels are 4.1.0 and 3.10.0 .
I have looked into the patches, and it seems that not everything has
made it into mainline.