Package Details: intel_nuc_led-dkms-git r2.65e93ef-1

Git Clone URL: https://aur.archlinux.org/intel_nuc_led-dkms-git.git (read-only, click to copy)
Package Base: intel_nuc_led-dkms-git
Description: Intel NUC7i[x]BN and NUC6CAY LED Control for Linux (DKMS)
Upstream URL: https://github.com/milesp20/intel_nuc_led
Licenses: GPL3
Submitter: zauguin
Maintainer: zauguin
Last Packager: zauguin
Votes: 1
Popularity: 0.013084
First Submitted: 2017-11-27 14:42
Last Updated: 2017-12-08 00:21

Dependencies (2)

Required by (0)

Sources (2)

Latest Comments

benjaminvialle commented on 2020-05-01 14:12

Hi,

Thank you for your answer. I'll create a new AUR package for it.

Edit: https://aur.archlinux.org/packages/intel_nuc_led-nuc8-dkms-git/

zauguin commented on 2020-05-01 14:11

Hi Benjamin Vialle,

thanks for your interest. While I will look into the compatibility issues with current kernels, I don not feel comfortable switching to your branch. While it certainly looks very interesting, it targets different hardware and additionally uses a quite different interface.

So I think your branch is more an independent package than a update for this one, so I would recommend creating a new AUR package for it.

benjaminvialle commented on 2020-04-26 13:50

Hi,

I recently bought an Intel NIC8i7HVK (Hades) Canyon, with the « skull » LED.

I tried to activate them and installed your AUR package, based on the Linux kernel module created by milesp20 (https://github.com/milesp20/intel_nuc_led). Unfortunately, this kernel module is not working with my material. nomego (https://github.com/nomego/intel_nuc_led) forked the kernel module and made it work. This forked module is not maintained anymore and doesn't work with recent kernels (5.6.6 on ArchLinux nowadays).

I have forked the kernel module on my Github account (https://github.com/benjaminvialle/intel_nuc_led), made needed updates and I have updated the PKGBUILD for AUR (see https://github.com/benjaminvialle/intel_nuc_led-dkms-git/blob/master/PKGBUILD)

Would it be possible to update your AUR repository ?

Let me know if I can help in any way.