Package Details: ipx 1.1-3

Git Clone URL: (read-only)
Package Base: ipx
Description: IPX userspace tools
Upstream URL:
Licenses: custom
Submitter: None
Maintainer: foxxy
Last Packager: foxxy
Votes: 16
Popularity: 0.000261
First Submitted: 2007-05-04 08:57
Last Updated: 2015-06-20 12:53

Dependencies (1)

Required by (0)

Sources (2)

Latest Comments

draringi commented on 2013-06-05 16:06

Updated the package to current makepkg standards, and moved binaries to /usr/bin to fit new filesystem standard

grawity commented on 2012-06-02 09:47

Cleaned up PKGBUILD:

Anonymous comment on 2011-04-15 10:16

Found same source file here:

Anonymous comment on 2011-04-02 20:08

The source doesn't seem to be available anymore :(

PiousMinion commented on 2010-05-29 16:27

Thanks for the nudge in the right direction. I had downgraded the kernel26 and kernel26-headers to 2.6.32. I had no clue there was a linux-api-headers as well. Compiles and works fine now. :D

Anonymous comment on 2010-05-29 09:09

This works for me, and it looks like something is off with your kernel headers.

What's your output for:

pacman -Q kernel26-headers
pacman -Q linux-api-headers

PiousMinion commented on 2010-05-29 03:31

This fails to build. :(
I really need this as I don't see any other way to support ipx.

==> Starting build()...
patching file ipx_configure.c
patching file ipx_interface.c
patching file ipx_internal_net.c
patching file ipx_route.c
gcc -O2 -Wall -Wl,--hash-style=gnu -Wl,--as-needed ipx_configure.c -o ipx_configure
In file included from /usr/include/sys/socket.h:40:0,
from ipx_configure.c:13:
/usr/include/bits/socket.h:366:24: fatal error: asm/socket.h: No such file or directory
compilation terminated.
make: *** [ipx_configure] Error 1
==> ERROR: Build Failed.