Package Details: ipxe-netboot r5942.ebff21a5-1

Git Clone URL: https://aur.archlinux.org/ipxe-netboot.git (read-only, click to copy)
Package Base: ipxe-netboot
Description: iPXE build for Arch Linux netboot
Upstream URL: http://ipxe.org
Licenses: GPL
Submitter: brain0
Maintainer: hotaru
Last Packager: hotaru
Votes: 4
Popularity: 0.002706
First Submitted: 2016-06-03 11:14
Last Updated: 2020-06-01 04:18

Latest Comments

Misushot commented on 2020-06-01 10:05

it works now, thanks @hotaru.

Misushot commented on 2020-06-01 09:06

@hotaru sorry, i didn't mean it like that. i have build your package yesterday with an old arch without problems :)

yes that's an upstream bug. i will test your package now again.

hotaru commented on 2020-06-01 03:24

@misushot also, that's an upstream bug. I've added a workaround, but you should complain to upstream about it.

hotaru commented on 2020-06-01 03:19

@eolin @cyrinux test-netboot should be fixed now. took a bit to figure out the new syntax for qemu.

@misushot don't be such an asshole, I was already working on it.

Misushot commented on 2020-05-31 10:25

Hi Your Package ist Broken, please FIX it. Thanks

make[1]: *** [Makefile.housekeeping:1192: bin/ipxe.lkrn.tmp] Fehler 1
rm bin/version.ipxe.lkrn.o
make: *** [Makefile.housekeeping:276: bin/ipxe.lkrn] Fehler 2
==> FEHLER: Ein Fehler geschah in build().
    Breche ab...

cyrinux commented on 2020-05-30 21:39

Hi, package seems broken, could you please fix ? :) Thanks

eoli3n commented on 2020-04-25 13:48

test-netboot is broken with latest qemu.

❯ test-netboot
qemu-system-x86_64: -usbdevice disk:format=raw:fat:./fat: '-usbdevice' is deprecated, please use '-device usb-...' instead
qemu-system-x86_64: -usbdevice disk:format=raw:fat:./fat: could not add USB device 'disk:format=raw:fat:./fat'

hotaru commented on 2020-04-20 22:33

@tchernomax done.

tchernomax commented on 2020-04-19 18:59

https://bugs.archlinux.org/task/66315

You may have to apply this patch:

diff --git a/PKGBUILD b/PKGBUILD
index 409a41e..2913e0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,6 +40,7 @@ prepare() {
   echo '#define NET_PROTO_IPV6' >> config/local/general.h
   echo '#define DOWNLOAD_PROTO_HTTPS' >> config/local/general.h
   echo '#define IMAGE_TRUST_CMD' >> config/local/general.h
+  echo '#define NTP_CMD' >> config/local/general.h
 }

 build() {
diff --git a/arch.ipxe b/arch.ipxe
index af01aae..929ed80 100644
--- a/arch.ipxe
+++ b/arch.ipxe
@@ -1,3 +1,4 @@
 #!ipxe
 ifconf
-chain https://www.archlinux.org/releng/netboot/archlinux.ipxe || shell
+ntp pool.ntp.org
+chain https://ipxe.archlinux.org/releng/netboot/archlinux.ipxe || shell

hseara commented on 2019-02-07 15:33

The package is not working. "test-netboot" asks for /usr/share/ovmf/ovmf_code_x64 that has been renamed to /usr/share/ovmf/x64/OVMF_CODE.fd.

ERROR: /usr/share/ovmf/ovmf_code_x64.bin is missing, install the ovmf package.