Package Details: irccloud 0.16.0-1

Git Clone URL: https://aur.archlinux.org/irccloud.git (read-only, click to copy)
Package Base: irccloud
Description: Chat on IRC from anywhere, and never miss a message
Upstream URL: https://www.irccloud.com/
Licenses: Apache
Submitter: olegfink
Maintainer: Freso (olegfink, jwheare, ryzokuken)
Last Packager: Freso
Votes: 5
Popularity: 0.000000
First Submitted: 2016-03-27 14:34 (UTC)
Last Updated: 2021-01-14 22:50 (UTC)

Latest Comments

elichai2 commented on 2022-04-05 10:35 (UTC)

Build fails for me:

"~/.nvm/versions/node/v16.14.2/bin/yarn" install
yarn install v1.22.18
[1/4] Resolving packages...
[2/4] Fetching packages...
[3/4] Linking dependencies...
[4/4] Building fresh packages...
$ electron-builder install-app-deps
  • electron-builder  version=22.10.4
  • loaded configuration  file=~/.cache/yay/irccloud/src/irccloud-desktop-0.16.0/electron-builder.json
$ yarn run snyk-protect
yarn run v1.22.18
$ snyk protect
Successfully applied Snyk patches

Done in 2.63s.
Done in 6.69s.
yarn run v1.22.18
$ ~/.cache/yay/irccloud/src/irccloud-desktop-0.16.0/node_modules/.bin/electron-builder --linux deb --config.deb.compression=gz -c.electronDist /usr/lib/electron -c.electronVersion 18.0.1
  • electron-builder  version=22.10.4 os=5.17.1-arch1-1
  • loaded configuration  file=~/.cache/yay/irccloud/src/irccloud-desktop-0.16.0/electron-builder.json
  • writing effective config  file=dist/builder-effective-config.yaml
  • packaging       platform=linux arch=x64 electron=18.0.1 appOutDir=dist/linux-unpacked
  • copying Electron  source=/usr/lib/electron destination=~/.cache/yay/irccloud/src/irccloud-desktop-0.16.0/dist/linux-unpacked
  • building        target=deb arch=x64 file=dist/irccloud-desktop_0.16.0_linux_amd64.deb
  • downloading     url=https://github.com/electron-userland/electron-builder-binaries/releases/download/fpm-1.9.3-2.3.1-linux-x86_64/fpm-1.9.3-2.3.1-linux-x86_64.7z size=5.0 MB parts=1
  • downloaded      url=https://github.com/electron-userland/electron-builder-binaries/releases/download/fpm-1.9.3-2.3.1-linux-x86_64/fpm-1.9.3-2.3.1-linux-x86_64.7z duration=2.354s
  ⨯ cannot execute  cause=exit status 127
                    errorOut=~/.cache/electron-builder/fpm/fpm-1.9.3-2.3.1-linux-x86_64/lib/ruby/bin.real/ruby: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory

                    command=~/.cache/electron-builder/fpm/fpm-1.9.3-2.3.1-linux-x86_64/fpm -s dir --force -t deb -d libgtk-3-0 -d libnotify4 -d libnss3 -d libxss1 -d libxtst6 -d xdg-utils -d libatspi2.0-0 -d libuuid1 -d libappindicator3-1 -d libsecret-1-0 --deb-compression gz --architecture amd64 --name irccloud-desktop --after-install /tmp/t-12tjLI/0-after-install --after-remove /tmp/t-12tjLI/1-after-remove --description '
     IRCCloud Desktop Client' --version 0.16.0 --package ~/.cache/yay/irccloud/src/irccloud-desktop-0.16.0/dist/irccloud-desktop_0.16.0_linux_amd64.deb --maintainer 'IRCCloud Ltd. <team@irccloud.com>' --url https://github.com/irccloud/irccloud-desktop --vendor 'IRCCloud Ltd. <team@irccloud.com>' --license Apache-2.0 ~/.cache/yay/irccloud/src/irccloud-desktop-0.16.0/dist/linux-unpacked/=/opt/IRCCloud ~/.cache/yay/irccloud/src/irccloud-desktop-0.16.0/dist/.icon-set/icon_16x16.png=/usr/share/icons/hicolor/16x16/apps/irccloud.png ~/.cache/yay/irccloud/src/irccloud-desktop-0.16.0/dist/.icon-set/icon_32.png=/usr/share/icons/hicolor/32x32/apps/irccloud.png ~/.cache/yay/irccloud/src/irccloud-desktop-0.16.0/dist/.icon-set/icon_48x48.png=/usr/share/icons/hicolor/48x48/apps/irccloud.png ~/.cache/yay/irccloud/src/irccloud-desktop-0.16.0/dist/.icon-set/icon_64.png=/usr/share/icons/hicolor/64x64/apps/irccloud.png ~/.cache/yay/irccloud/src/irccloud-desktop-0.16.0/dist/.icon-set/icon_128.png=/usr/share/icons/hicolor/128x128/apps/irccloud.png ~/.cache/yay/irccloud/src/irccloud-desktop-0.16.0/dist/.icon-set/icon_256.png=/usr/share/icons/hicolor/256x256/apps/irccloud.png ~/.cache/yay/irccloud/src/irccloud-desktop-0.16.0/dist/.icon-set/icon_512.png=/usr/share/icons/hicolor/512x512/apps/irccloud.png ~/.cache/yay/irccloud/src/irccloud-desktop-0.16.0/dist/.icon-set/icon_1024.png=/usr/share/icons/hicolor/1024x1024/apps/irccloud.png /tmp/t-12tjLI/2-IRCCloud.desktop=/usr/share/applications/irccloud.desktop

Seems like electron-builder downloads an old ruby binary that expects the deprecated libcrypt.so.1

Freso commented on 2020-03-06 20:25 (UTC)

If you notice the package is outdated, please just flag the package accordingly.

ryzokuken commented on 2020-03-06 12:08 (UTC)

Anyone still working on maintaining this? I'm willing to help out...

jwheare commented on 2019-07-15 10:09 (UTC)

This might just be because the executable name changed from irccloud-desktop to just irccloud

Freso commented on 2019-07-13 13:01 (UTC)

makepkg’ing the PKGBUILD seems to break with 0.11.0. I’ll probably need to consult jwheare before releasing an updated PKGBUILD. Sorry for the delay.

jfhbrook commented on 2019-04-13 00:52 (UTC)

Actually, I had to make a few changes:

1) node-gyp has to be installed as a makedepend 2) python2 has to be installed as a makedepend - for whatever reason the package doesn't pull it in 3) node-gyp by default tries to use /usr/bin/python so I had to set PYTHON=/usr/bin/python2 in the build step 4) xorg-server is also a makedepend - I was running this in a chroot with aurutils so I caught /all/ of these lol

so my working PKGBUILD looks like this: https://gist.github.com/jfhbrook/f8421052402666c4d91d969e63baf3da

jfhbrook commented on 2019-04-13 00:13 (UTC)

This package needs node-gyp as a build dependency

Freso commented on 2017-10-09 13:45 (UTC)

Please change the tarball source to use a package specific name for the source file. See https://wiki.archlinux.org/index.php/PKGBUILD#source

Freso commented on 2017-10-03 13:24 (UTC)

@s0undt3ch, see https://wiki.archlinux.org/index.php/Arch_User_Repository#Foo_in_the_AUR_is_outdated.3B_what_do_I_do.3F (hint: flagging is better than commenting for out-of-date packages)

s0undt3ch commented on 2017-10-03 11:00 (UTC)

v0.4.0 was released today (Oct. 3rd 2017). Can we get an update?

chocoelho commented on 2016-10-06 18:29 (UTC)

Hi, tarball needs to be updated to https://github.com/irccloud/irccloud-desktop/archive/v0.3.0.tar.gz

MoroS commented on 2016-08-16 12:11 (UTC)

Hi. electron-bin is already deprecated. Electron has been added to the community repository as "electron", so please update your dependencies (again, sorry :P ), as electron-bin will not be updated anymore.

inanimate commented on 2016-08-05 18:46 (UTC)

Also, electron needs to be updated to electron-bin: https://aur.archlinux.org/packages/electron-bin/