Package Details: ironahk-git 20120716-1

Git Clone URL: https://aur.archlinux.org/ironahk-git.git (read-only)
Package Base: ironahk-git
Description: Cross platform .NET rewrite of the popular AutoHotkey scripting language for desktop automation
Upstream URL: http://www.ironahk.net/
Licenses: custom
Submitter: allencch
Maintainer: None
Last Packager: allencch
Votes: 9
Popularity: 0.041426
First Submitted: 2012-02-16 08:30
Last Updated: 2015-06-09 08:29

Required by (0)

Sources (0)

Latest Comments

allencch commented on 2017-12-19 05:33

@Archeon Looks like it is not active any more.

Archeon commented on 2017-12-19 04:32

I'm getting the following warning when I run any script:

WARNING: The runtime version supported by this application is unavailable.

Using default runtime: v4.0.30319

If I run a basic script to click, it will move the mouse but the click won't actually happen. Not sure if this is related.

Also, the upstream url http://www.ironahk.net/ isn't functioning.

flying-sheep commented on 2013-09-19 19:21

hi, when i run it on any of the two scripts here: http://superuser.com/questions/519151/mouse-double-click-min-interval/519166#519166

it just says:
No protocol specified
Buggy-Mouse.ahk (0): ==> Object reference not set to an instance of an object
Buggy-Mouse.ahk (0): ==> An exception was thrown by the type initializer for IronAHK.Scripting.Script
Compilation failed.
No protocol specified

allencch commented on 2012-02-25 15:51

OK100, thank you for your fix. I have update the PKBUILD. I didn't have this problem because previously the package was built on NTFS.

allencch commented on 2012-02-25 15:50

OK100, thank you for your script. I have update the PKBUILD. I didn't have this problem because previously the package was built on NTFS.

OK100 commented on 2012-02-25 13:51

Here is ugly fix:
https://gist.github.com/1908569

OK100 commented on 2012-02-25 13:36

Gives me following error:

"Deploy/bin/Release/setup.sh" install
/bin/sh: Deploy/bin/Release/setup.sh: Permission denied
make: *** [install] Error 126
==> ERROR: A failure occurred in package().
Aborting...

OK100 commented on 2012-02-25 13:29

Gives me following error:

"Deploy/bin/Release/setup.sh" install
/bin/sh: Deploy/bin/Release/setup.sh: Permission denied
make: *** [install] Error 126
==> ERROR: A failure occurred in package().
Aborting...