Package Details: itk-git 4.10rc02.25.gbf3f02c-1

Git Clone URL: https://aur.archlinux.org/itk-git.git (read-only, click to copy)
Package Base: itk-git
Description: Open-source, cross-platform C++ toolkit for segmentation and registration
Upstream URL: http://www.itk.org
Licenses: Apache
Conflicts: insight-toolkit, insight-toolkit-git, itk
Provides: insight-toolkit, insight-toolkit-git, itk
Submitter: pmattern
Maintainer: pmattern
Last Packager: pmattern
Votes: 1
Popularity: 0.000000
First Submitted: 2016-05-02 16:19
Last Updated: 2016-05-24 13:55

Required by (18)

Sources (1)

Latest Comments

javierbg commented on 2021-01-21 11:15

Can't install the package without the eigen package installed. After installing, I get no additional errors when building.

flipmess commented on 2020-08-25 00:10

compiles after installing community/gtest

flipmess commented on 2020-08-24 21:27

hi, this does not compile: ... -- Found EXPAT: /usr/lib/libexpat.so (found version "2.2.9") CMake Error at /usr/share/cmake-3.18/Modules/FindPackageHandleStandardArgs.cmake:165 (message): Could NOT find GTest (missing: GTEST_LIBRARY GTEST_INCLUDE_DIR GTEST_MAIN_LIBRARY) Call Stack (most recent call first): /usr/share/cmake-3.18/Modules/FindPackageHandleStandardArgs.cmake:458 (_FPHSA_FAILURE_MESSAGE) /usr/share/cmake-3.18/Modules/FindGTest.cmake:205 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) Modules/ThirdParty/GoogleTest/itk-module-init.cmake:36 (find_package) CMake/ITKModuleEnablement.cmake:321 (include) CMakeLists.txt:481 (include)

-- Configuring incomplete, errors occurred! See also "/home/flipmess/.cache/yay/itk-git/src/build/CMakeFiles/CMakeOutput.log". See also "/home/flipmess/.cache/yay/itk-git/src/build/CMakeFiles/CMakeError.log". ==> ERROR: A failure occurred in build(). Aborting... error making: itk-git

pmattern commented on 2016-12-27 01:55

Package gdcm-git is building flawlessly here, last checked with c6cf0b4df. If you're really still having trouble compiling you'd better report at https://aur.archlinux.org/packages/gdcm-git.
Similarly, I could not confirm the need to set ITKV3_COMPATIBILITY to compile, no matter whether itk-git was built against gdcm-git or, after tweaking its PKGBUILD, against gdcm. So if you still think tweaking the variable is needed please elaborate your findings.
Given that one main purpose of VCS packages is testing I for one think at least the most important dependencies should be provided as recent development versions as well which in turn is pragmatically easier when the latter are stated by the PKGBUILDs in question right away. For that reason I'm not too much in favor of having this package depend on gdcm again.

dvogel commented on 2016-12-20 13:04

Hey, thanks for this PKGBUILD,
- I would suggest changing dependency from gdcm-git to gdcm as the former doesn't build and the latter is more popular.
- Adding -DITKV3_COMPATIBILITY=ON flag was also required to get itk-snap to build, it would save a few minutes to include it in the PKGBUILD and doesn't add much overhead.