Package Details: jack2-git 1:1.9.16.r0.g5b78c2ef-1

Git Clone URL: https://aur.archlinux.org/jack2-git.git (read-only, click to copy)
Package Base: jack2-git
Description: C++ version of the JACK low-latency audio server for multi-processor machines
Upstream URL: http://jackaudio.org/
Keywords: audio cv jack midi
Licenses: GPL2, LGPL2.1
Groups: pro-audio
Conflicts: jack, jack2
Provides: jack, jack=1.9.16, jack2, jack2=1.9.16, libjack.so, libjacknet.so, libjackserver.so
Replaces: jack2-dbus-git
Submitter: longname
Maintainer: milk (dvzrv, SpotlightKid)
Last Packager: SpotlightKid
Votes: 8
Popularity: 0.000182
First Submitted: 2012-03-04 20:18
Last Updated: 2020-10-19 15:59

Dependencies (26)

Required by (590)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

Terence commented on 2019-08-31 09:28

Hey, it's because I'm using wineasio-git/fsthost for standalone windows plugins.

Ralf_Mardorf commented on 2019-08-31 09:25

Hi, I'm interested in a dependency tree. Why do you need lib32-jack or lib32-jack2? I'm not using jack2-git, however, I'm not aware that in 2019 something really requires a 32 bit jack library. Don't get me wrong, I don't claim that the 32 bit library is useless at all. Are you sure that something installed on your machine still depends on the 32 bit library?

Did you try to remove lib32-jack, install jack2-git and then to install lib32-jack2?

Terence commented on 2019-08-31 08:47

I'm getting removing jack2-dbus-git breaks dependency 'jack2' required by lib32-jack2 when trying to replace jack2-dbus-git by this package.

SpotlightKid commented on 2019-02-08 22:28

@milk: Thank you!

milk commented on 2019-02-08 20:37

fixed a few days ago. also making you a mod of the package cos bottlenecks can hinder.

SpotlightKid commented on 2019-01-23 13:13

The --freebob option was just removed from ./waf configure. The build() function in the PKGBUILD needs to be adapted accordingly.

https://github.com/jackaudio/jack2/commit/6d2302a803d9a2610f0ef240f1f1bc608d3b2fb2

SpotlightKid commented on 2019-01-17 19:03

The 'waf' script in the current repo runs with Python 3 without problems. All occurrences of 'python2' in the the PKGBUILD file can be replaced with just 'python'.

milk commented on 2017-05-17 08:35

flagging out of date as;

==> Making package: faustlive-git 783.c84e4a5-1 (Wed 17 May 09:31:06 BST 2017)
==> Checking runtime dependencies...
==> Installing missing dependencies...
resolving dependencies...
looking for conflicting packages...
:: jack2 and jack2-git are in conflict (jack). Remove jack2-git? [y/N]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: jack2 and jack2-git are in conflict
==> ERROR: 'pacman' failed to install missing dependencies.
:: failed to build faustlive-git package(s)

milk commented on 2017-01-28 15:59

should provide jack2 rather than jackdbus now?

greygjhart commented on 2016-12-30 18:10

Hi,
Huh, thanks for the feedback ! I don't really recall having read Ralf's proposal at all and I apologize for that. I'm sort of unable to build packages locally at the mo but I'll try and take a look later. Thanks anyway.