Package Details: jalv-git 1.6.7.r530.08ca5ba-1

Git Clone URL: (read-only, click to copy)
Package Base: jalv-git
Description: A simple but fully featured LV2 host for Jack (git version)
Upstream URL:
Licenses: custom:ISC
Conflicts: jalv
Provides: jalv
Submitter: SpotlightKid
Maintainer: SpotlightKid
Last Packager: SpotlightKid
Votes: 0
Popularity: 0.000000
First Submitted: 2016-02-11 00:04 (UTC)
Last Updated: 2021-03-11 15:19 (UTC)

Latest Comments

SpotlightKid commented on 2020-05-17 15:15 (UTC) (edited on 2020-05-17 15:16 (UTC) by SpotlightKid)

Yes, but those guidelines where only added fairly recently and conflict with the guidelines linked to in the same paragraph ("Dependencies that are provided by other dependencies do not need to be listed.") ;-/

Lucki commented on 2020-05-17 15:03 (UTC)

Thanks :) Guess that's why the guidelines advice to "[…] not rely on transitive dependencies […]":

SpotlightKid commented on 2020-05-17 14:12 (UTC)

Oh, I see. The dependencies of the lv2 related packages (lilv, sratom, sord, etc.) have changed fairly often in the past and often differ from the respective -git packages, which I generally use.

Anyway, I'll add lv2>=1.17.2 to makedepends.

Lucki commented on 2020-05-17 13:48 (UTC)

lilv only depends on lv2 at the build time of lilv (make dependency). lv2 isn't a indirect dependency and not present in a clean build environment at the build time of jalv-git.

SpotlightKid commented on 2020-05-17 13:21 (UTC)

lv2 is an indirect dependency via lilv. The lv2 package community is already at version 0.18.0, so should meet the required minimum version. And if you have lilv-git installed and it is still at a lower version, just rebuild & reinstall it.

Lucki commented on 2020-05-17 12:51 (UTC) (edited on 2020-05-17 12:51 (UTC) by Lucki)

Hey there, the build is failing because it's missing lv2:

Checking for 'lv2 >= 1.17.2'                  : not found 
The configuration failed
(complete log in /build/jalv-git/src/jalv/build/config.log)
==> ERROR: A failure occurred in build().