Package Details: janusvr 59.8-1

Git Clone URL: https://aur.archlinux.org/janusvr.git (read-only)
Package Base: janusvr
Description: 3D VR internet browser
Upstream URL: http://www.dgp.toronto.edu/~mccrae/projects/firebox/
Licenses: custom
Submitter: haagch
Maintainer: haagch
Last Packager: haagch
Votes: 5
Popularity: 0.032715
First Submitted: 2015-06-16 14:27
Last Updated: 2018-01-22 12:57

Latest Comments

marcs commented on 2018-02-03 17:38

Missing dependency: libpng12

haagch commented on 2018-01-22 13:01

No offence taken, I haven't updated this in months.

In the past he released updates very frequently and I didn't want to constantly be busy updating the package. Now that the releases have slowed down a bit and the focus of the community shifted to JanusWeb I might switch to versioned and checksummed updates.

JanusWeb is still quite useless on Linux because still no browser supports VR hardware on Linux...

JanusVR isn't working great either with random crashes, constant memory management related warnings and video playback being completely broken (as far as I can tell) but it's something...

Eschwartz commented on 2018-01-22 12:21

Just for the record, filing an orphan request first thing, before asking politely here, is unacceptable. ;)

haagch, sorry you had to deal with this.

BTW your pkgdesc is self-referential, please look at https://wiki.archlinux.org/index.php/PKGBUILD#pkgdesc and remove the first couple of words from there.

Typically, PKGBUILDs like this that build from unversioned upstream sources simply contain a hardcoded pkgver and the maintainer periodically updates this... ignoring the checksums is not very nice...

haagch commented on 2018-01-22 07:53

To the orphan request because of missing logo: Sorry, I was always building from my existing directory which didn't re-download the logo so I didn't notice they changed the location. Now it should build again.

kremfaen commented on 2017-10-20 19:07

It does not want to update for me. I keep getting
:: janusvr package(s) failed to install.
:: ensure package version does not mismatch between .SRCINFO and PKGBUILD
:: ensure package name has a VCS suffix if this is a devel package

haagch commented on 2016-10-11 12:57

For updates just run the installation of this package again.

They only have one unchanging download link http://downloads.janusvr.com/janusvr_linux.tar.gz
and the package version is updated from http://www.janusvr.com/version.html every time you run makepkg.

haagch commented on 2016-10-08 09:51

Indeed it was. Looks like they have an actual logo now.

kremfaen commented on 2016-10-08 09:45

The janus_logo5.jpg url is broken.

haagch commented on 2016-06-27 19:28

Thanks.

If for anyone "convert" crashes because of some assertion regarding OpenCL, it's an imagemagick bug that has been fixed in up to date imagemagick versions. E.g. build imagemagick with
pkgver=7.0.2.1
It's been flagged out of date for a while..

kremfaen commented on 2016-06-27 18:28

Heads up! The download link has changed to http://downloads.janusvr.com/janusvr_linux.tar.gz

All comments