Package Details: jasper-voice-control-git 0.0.0-2

Git Clone URL: https://aur.archlinux.org/jasper-voice-control-git.git (read-only, click to copy)
Package Base: jasper-voice-control-git
Description: Jasper is an open source platform for developing always-on, voice-controlled applications.
Upstream URL: https://jasperproject.github.io
Licenses: MIT
Conflicts: jasper-voice-control
Provides: jasper-voice-control
Submitter: Holzhaus
Maintainer: Holzhaus
Last Packager: Holzhaus
Votes: 8
Popularity: 0.000000
First Submitted: 2014-10-13 16:44 (UTC)
Last Updated: 2016-05-03 08:13 (UTC)

Dependencies (15)

Required by (6)

Sources (3)

Latest Comments

Alkaris commented on 2020-08-18 05:45 (UTC)

This package keeps asking for python2-tzlocal when installing python2-apscheduler but it doesn't exist and can't be installed, it's just python-tzlocal now.

could not satisfy dependencies:
- unable to satisfy dependency 'python2-tzlocal' required by python2-apscheduler
- unable to satisfy dependency 'python2-apscheduler' required by jasper-voice-control-git

Can't even amend the PKGBUILD to tell it to use python-tzlocal instead.

luntik2012 commented on 2019-04-21 07:09 (UTC)


jasper-voice-control-git 0.0.0-2  (2016-05-03 08:13)
( Unsupported package: Potentially dangerous ! )
==> jasper-voice-control-git dependencies:
 - python2 (already installed)
 - python2-apscheduler (building from AUR)
 - python2-argparse (building from AUR)
 - python2-mock (package found)
 - python2-pip (package found)
 - python2-pyaudio (building from AUR)
 - python2-requests (package found)
 - python2-yaml (package found)
 - git (package found) [makedepend]


==> Continue building jasper-voice-control-git ? [Y/n]
==> --------------------------------------------------
==> 
==> Building and installing package
==> Install or build missing dependencies for jasper-voice-control-git:
[sudo] password for nikita: 
error: target not found: python2-argparse
==> Restart building jasper-voice-control-git ? [y/N]
==> -------------------------------------------------

FlorianJacob commented on 2016-02-17 16:00 (UTC)

My patch using the version recommended it the packaging guidelines for repositories with no tags: PKGBUILD | 9 +++++---- 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/PKGBUILD b/PKGBUILD index ee0fd0e..9bbec47 100644 --- a/PKGBUILD +++ b/PKGBUILD @@ -1,8 +1,8 @@ pkgname=jasper-voice-control-git -pkgver=0.0.0 -pkgrel=2 +pkgver=r447.e6789d7 +pkgrel=3 pkgdesc="Jasper is an open source platform for developing always-on, voice-controlled applications." arch=('any') url="https://jasperproject.github.io" @@ -34,8 +34,9 @@ install='jasper-voice-control.install' pkgver() { cd "${srcdir}/jasper-client" - # Use the tag of the last commit - git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g' + # the git repo has no tags, so use number of revisions since beginning of history + # See https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git + printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" } prepare() { -- 2.7.1

undrwater commented on 2016-02-06 00:28 (UTC)

OK...changed git describe --long to git describe --always That seemed to work.

undrwater commented on 2016-02-06 00:19 (UTC)

-> Creating working copy of jasper-client git repo... Reset branch 'makepkg' ==> Starting pkgver()... fatal: No names found, cannot describe anything. ==> ERROR: pkgver is not allowed to be empty. ==> ERROR: pkgver() generated an invalid version: ==> ERROR: Makepkg was unable to build jasper-voice-control-git. Fails with the above.

Anthony25 commented on 2016-01-15 09:08 (UTC)

Hello, You should add "python2-feedreeder" as dependency, as it is needed for the populate script.

kwirkie commented on 2015-03-05 11:19 (UTC)

Added this to remove some files which are git repository related (there may be more files that I've missed): rm -r "${srcdir}/jasper-client/"{.git,.gitignore,.coveragerc,.travis.yml} Also added the below to stop it overwriting the configuration when updating: backup=('var/lib/jasper/.jasper/profile.yml')

Holzhaus commented on 2014-10-25 22:13 (UTC)

Just edit the pyaudio PKGBUILD and add 'armv6h' to the arch=(...) list.

jonaz commented on 2014-10-25 14:49 (UTC)

I have a problem with dependency python2-pyaudio: ==> ERROR: python2-pyaudio is not available for the 'armv6h' architecture. Note that many packages may need a line added to their PKGBUILD such as arch=('armv6h'). The build failed. Dependencies for `jasper-voice-control-git' are not met, not building...