Package Details: java-berkeleydb 5.3.28-4

Git Clone URL: https://aur.archlinux.org/java-berkeleydb.git (read-only)
Package Base: java-berkeleydb
Description: Java bindings for the Berkeley DB embedded database system
Upstream URL: http://www.oracle.com/technology/software/products/berkeley-db/index.html
Licenses: custom
Submitter: bfrog
Maintainer: externl
Last Packager: externl
Votes: 15
Popularity: 0.919748
First Submitted: 2008-09-07 19:41
Last Updated: 2015-09-02 13:09

Latest Comments

disastro commented on 2016-04-11 09:23

I flagged this outdated when I shouldn't have probably, didn't notice at that time the license change and everything.

externl commented on 2015-09-02 13:10

Thanks, should be fixed now.

meZee commented on 2015-09-02 02:49

The package release should be 4 instead of 3 in PKGBUILD on line 6. Pacman is expecting it as that is what's in the .SRCINFO, and not using it causes java-berkeleydb to be 'updated' every time you run the update parameters with Pacman.

externl commented on 2015-06-05 15:01

I use this package for work so I'm happy to maintain it. I've updated with a patch for building with Java 8.

externl commented on 2015-06-05 14:11

Is anyone against patching this to work with Java 8?

Innominate8 commented on 2015-03-01 16:08

This will only build under jdk7.

soker commented on 2014-11-08 12:48

@noctua @OttoA I tested with Oracle Java 8 and OpenJDK and I have the same problem.

noctua commented on 2014-11-03 10:14

@dape: I was getting the same error with jni, I just moved the .h-files to the current directory. Modifyingthe paths would work, too, but that would require more changes in other files than the PKGBUILD.

@OttoA: I'm also getting the same error as @soker. Note that I am doing this with Java 1.8 (openjdk).

OttoA commented on 2014-10-29 20:11

Bumped to recent version.

Couldn't replicate the errors by @soker and @dape though.

soker commented on 2014-10-24 21:57

Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
env CLASSPATH="./classes" java -classpath ./classes \
com.sleepycat.persist.model.ClassEnhancer ./classes
java.lang.IllegalArgumentException
at com.sleepycat.asm.ClassReader.<init>(ClassReader.java:167)
at com.sleepycat.asm.ClassReader.<init>(ClassReader.java:153)
at com.sleepycat.persist.model.ClassEnhancer.enhanceBytes(ClassEnhancer.java:297)
at com.sleepycat.persist.model.ClassEnhancer.enhanceFile(ClassEnhancer.java:246)
at com.sleepycat.persist.model.ClassEnhancer.enhanceFile(ClassEnhancer.java:242)
at com.sleepycat.persist.model.ClassEnhancer.enhanceFile(ClassEnhancer.java:242)
at com.sleepycat.persist.model.ClassEnhancer.enhanceFile(ClassEnhancer.java:242)
at com.sleepycat.persist.model.ClassEnhancer.enhanceFile(ClassEnhancer.java:242)
at com.sleepycat.persist.model.ClassEnhancer.main(ClassEnhancer.java:108)
Exception in thread "main" java.lang.IllegalArgumentException
at com.sleepycat.asm.ClassReader.<init>(ClassReader.java:167)
at com.sleepycat.asm.ClassReader.<init>(ClassReader.java:153)
at com.sleepycat.persist.model.ClassEnhancer.enhanceBytes(ClassEnhancer.java:297)
at com.sleepycat.persist.model.ClassEnhancer.enhanceFile(ClassEnhancer.java:246)
at com.sleepycat.persist.model.ClassEnhancer.enhanceFile(ClassEnhancer.java:242)
at com.sleepycat.persist.model.ClassEnhancer.enhanceFile(ClassEnhancer.java:242)
at com.sleepycat.persist.model.ClassEnhancer.enhanceFile(ClassEnhancer.java:242)
at com.sleepycat.persist.model.ClassEnhancer.enhanceFile(ClassEnhancer.java:242)
at com.sleepycat.persist.model.ClassEnhancer.main(ClassEnhancer.java:108)
Makefile:973: recipe for target 'db.jar' failed
make: *** [db.jar] Error 1
==> ERROR: Se produjo un error en build().
Cancelando...
==> ERROR: Makepkg no ha podido compilar java-berkeleydb.

dape commented on 2014-10-08 23:35

/libtool --mode=compile cc -c -I. -I../src -D_FORTIFY_SOURCE=2 -D_GNU_SOURCE -D_REENTRANT -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -fno-strict-aliasing ../lang/java/libdb_java/db_java_wrap.c
libtool: compile: cc -c -I. -I../src -D_FORTIFY_SOURCE=2 -D_GNU_SOURCE -D_REENTRANT -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -fno-strict-aliasing ../lang/java/libdb_java/db_java_wrap.c -fPIC -DPIC -o .libs/db_java_wrap.o
../lang/java/libdb_java/db_java_wrap.c:137:17: fatal error: jni.h: No such file or directory
#include <jni.h>
^
compilation terminated.
Makefile:2449: recipe for target 'db_java_wrap.lo' failed
make: *** [db_java_wrap.lo] Error 1
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build java-berkeleydb.

ASzc commented on 2012-08-24 23:28

Patch for update to 5.3.21: http://ix.io/2Qf

ASzc commented on 2012-08-24 22:37

You can get a direct download link by dropping the /otn from the URLs provided on the Oracle pages.

OttoA commented on 2012-01-20 13:52

I bumped it to 5.3.15 and I don't pull from oracle anymore (requires some kind of signon)

Athemis commented on 2012-01-19 13:08

5.1.25 is no longer available for download. Latest release in the 5.1 series is 5.1.29.

OttoA commented on 2011-06-05 14:59

But ./configure should figure out where to put the files. I'll leave it as it is for the moment and look into it when I have the time.

ezzetabi commented on 2011-06-02 17:10

No, that was the point. First I simply installed your package (so the .la file only) for the Berkeley db java bindings. And hypergraphdb did not work (UnsatisfiedLinkError if I recall correctly); it started to work only when I copied libdb_java-5.1.so. Maybe the openjdk6 JNI needs the .so files?

ezzetabi commented on 2011-06-02 16:49

No, that was the point. First I simply installed your package (so the .la file only) for the Berkeley db java bindings. And hypergraphdb did not work (UnsatisfiedLinkError if I recall correctly); it started to work only when I copied libdb_java-5.1.so. Maybe the openjdk6 JNI needs the .so files?

OttoA commented on 2011-06-02 08:53

exactly, the .la file is an archive containing the .so file. Does your program still work when deleting the .so file while keeping the .la file?

ezzetabi commented on 2011-06-02 08:35

I was tring hypergraphdb; but the library cannot find its native implementation of java-berkeleydb related methods.
When I copied the libdb_java-5.1.so file in the /usr/lib directory it started to work.

I am not sure I understood, but you mean that the .la file should already contain the shared libraries. Right?

OttoA commented on 2011-06-01 16:46

Generally you only need to copy the files that end up in $pkgdir, which is among others usr/lib/libdb_java-5.1.la in this case.

The tests run fine on my machine, why do you think you need the .so file?

ezzetabi commented on 2011-06-01 16:18

You forgot to copy the .so file, just add this line in the package function.

install -Dm644 "$srcdir"/db-"$pkgver"/build_unix/.libs/libdb_java-5.1.so \
"$pkgdir"/usr/lib/libdb_java-5.1.so