Package Details: java-elektra-git 0.8.19.r8926.b9456f4ac-1

Git Clone URL: https://aur.archlinux.org/elektra-git.git (read-only)
Package Base: elektra-git
Description: Java bindings for Elektra. (GIT version)
Upstream URL: http://libelektra.org
Licenses: BSD
Conflicts: java-elektra
Provides: java-elektra
Submitter: sl1pkn07
Maintainer: sl1pkn07
Last Packager: sl1pkn07
Votes: 2
Popularity: 0.000108
First Submitted: 2014-03-21 21:09
Last Updated: 2017-01-19 23:15

Latest Comments

sl1pkn07 commented on 2016-12-25 22:08

@parakov try now

sl1pkn07 commented on 2016-12-24 17:47

https://github.com/ElektraInitiative/libelektra/issues/1233

patrakov commented on 2016-12-24 16:46

This package is just too fat for use with oyranos-git. Also, it doesn't work (to test, run "oyranos-monitor" without parameters):

WARNING 0,032915: [-1] oyranos_cmm_elDB.c:236 oyDB_printWarn() error: number description ingroup module file line function reason
WARNING 0,032944: [-1] oyranos_cmm_elDB.c:236 oyDB_printWarn() error/configfile:
WARNING 0,032967: [-1] oyranos_cmm_elDB.c:236 oyDB_printWarn() error/description: failed to open default backend (see warnings for more information)
WARNING 0,032990: [-1] oyranos_cmm_elDB.c:236 oyDB_printWarn() error/file: /home/aep/compiz0.8-pkgs/elektra-git/src/elektra/src/libs/elektra/kdb.c
WARNING 0,033014: [-1] oyranos_cmm_elDB.c:236 oyDB_printWarn() error/ingroup: kdb
WARNING 0,033036: [-1] oyranos_cmm_elDB.c:236 oyDB_printWarn() error/line: 287
WARNING 0,033057: [-1] oyranos_cmm_elDB.c:236 oyDB_printWarn() error/module:
WARNING 0,033079: [-1] oyranos_cmm_elDB.c:236 oyDB_printWarn() error/mountpoint:
WARNING 0,033101: [-1] oyranos_cmm_elDB.c:236 oyDB_printWarn() error/number: 40
WARNING 0,033123: [-1] oyranos_cmm_elDB.c:236 oyDB_printWarn() error/reason: could not open default backend

strace suggests this might be the reason:

open("/usr/lib/libelektra-resolver.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)

beojan commented on 2016-12-02 14:46

This no longer builds. COPYING is now LICENSE.md, and the gi/python bindings are deprecated.

raetiacorvus commented on 2016-05-01 12:53

In addition the qt-gui also should optdepend on qt5-quickcontrols

raetiacorvus commented on 2016-05-01 12:47

Maybe drop the -DPLUGINS=ALL as upstream defaults now to -DPLUGINS=ALL;-experimental and experimental plugins are really that. The crypto plugin (is experimental) for example breaks the qt-gui at the moment.

cesasol commented on 2015-12-10 11:01

Error compiling, the log shows that the it can't link pthreads, it could be something from upstream?
-- Include Plugin counter
-- Include Plugin type
CMake Error at cmake/Modules/LibAddTest.cmake:51 (set_property):
set_property given TEST names that do not exist:

testmod_type

Call Stack (most recent call first):
src/plugins/type/CMakeLists.txt:11 (add_gtest)


-- Include Plugin constants
-- Include Plugin noresolver
-- Include Plugin wresolver
-- Include Plugin ini
-- Include Plugin list
-- Include Plugin logchange
-- Include Plugin glob
-- Include Plugin hosts
-- Include Plugin iconv
-- Include Plugin network
-- Include Plugin path
-- Include Plugin enum
-- Include Plugin mathcheck
-- Include Plugin conditionals
-- Include Plugin keytometa
-- Include Plugin rename
-- Include Plugin syslog
-- Include Plugin uname
-- Include Plugin timeofday
-- Include Plugin simpleini
-- Include Plugin line
-- Include Plugin validation
-- Include Plugin regexstore
-- Include Plugin filecheck
-- Include Plugin's build variant resolver_fm_b_b
-- Include Plugin's build variant resolver_fm_hb_b
-- Include Plugin's build variant resolver_fm_hp_b
-- Include Plugin's build variant resolver_fm_ub_x
-- Include Plugin's build variant resolver_fm_xb_x
-- Include Plugin's build variant resolver_fm_xp_x
-- Include Plugin's build variant resolver_fm_xhp_x
-- Include Plugin's build variant resolver_fm_uhb_xb
-- Include Plugin yajl
-- Include Plugin dbus
-- Include Plugin tcl
-- Boost version: 1.59.0
-- Include Plugin xmltool
-- Include Plugin augeas
-- Include Plugin journald
-- Include Plugin jni
-- Include Plugin python
CMake Warning at src/plugins/python/CMakeLists.txt:46 (message):
swig_python bindings are required for testing, test deactivated


-- Include Plugin python2
CMake Warning at src/plugins/python2/CMakeLists.txt:60 (message):
swig_python2 bindings are required for testing, test deactivated


-- Include Plugin lua
CMake Warning at src/plugins/lua/CMakeLists.txt:41 (message):
swig_lua bindings are required for testing, test deactivated


-- Include Plugin crypto
-- Found libgcrypt: -lgcrypt -lgpg-error
-- Include Binding cpp
-- Include Binding jna
-- Exclude Binding jna because jna jar file not found, searched in standard pathes and /usr/share/java
-- Include Binding swig
-- Include Binding swig_python2
-- Include Binding swig_python
-- Include Binding swig_lua
-- Include Binding glib
-- Include Binding gi_python
-- Include Binding gi_lua
-- Include Tool kdb
-- Configuring incomplete, errors occurred!
See also "/tmp/makepkg/elektra-git/src/build/CMakeFiles/CMakeOutput.log".
See also "/tmp/makepkg/elektra-git/src/build/CMakeFiles/CMakeError.log".

Pietro_Pizzi commented on 2015-09-30 19:14

... [all looks ok till] ...
-- Include Plugin jni
-- Could NOT find JNI (missing: JAVA_AWT_LIBRARY JAVA_JVM_LIBRARY)
-- Exclude Plugin jni because jni not found
-- Include Plugin python
-- Found PythonLibs: /usr/lib64/libpython3.4m.so (found suitable version "3.4.3", minimum required is "3")
-- Could NOT find SWIG (missing: SWIG_EXECUTABLE SWIG_DIR) (Required is at least version "3")
-- Search for swig2 instead
-- Exclude Plugin python because swig not found
-- Include Plugin python2
-- Found Python2Libs: /usr/lib64/libpython2.7.so (found suitable version "2.7.10", minimum required is "2.7")
-- Could NOT find SWIG (missing: SWIG_EXECUTABLE SWIG_DIR) (Required is at least version "3")
-- Search for swig2 instead
-- Exclude Plugin python2 because swig not found
-- Include Binding cpp
-- Include Binding jna
-- Found Java: /usr/bin/java (found version "1.8.0.60")
-- Exclude Binding jna because jna jar file not found, searched in standard pathes and /usr/share/java
-- Include Binding swig
-- Could NOT find SWIG (missing: SWIG_EXECUTABLE SWIG_DIR) (Required is at least version "3")
-- Search for swig2 instead
CMake Error at cmake/Modules/LibAddMacros.cmake:322 (MESSAGE):
LIST_FILTER: missing list variable.
Call Stack (most recent call first):
src/bindings/CMakeLists.txt:21 (list_filter)


-- Configuring incomplete, errors occurred!
See also "/tmp/yaourt-tmp-pietro/aur-elektra-git/src/build/CMakeFiles/CMakeOutput.log".
See also "/tmp/yaourt-tmp-pietro/aur-elektra-git/src/build/CMakeFiles/CMakeError.log".
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build elektra-git.

sl1pkn07 commented on 2015-09-11 13:31

try now

ni3k commented on 2015-09-11 09:56

Can not build, please help:

CMake Error at cmake/Modules/LibAddMacros.cmake:64 (target_link_libraries):
Cannot specify link libraries for target "testtool_mergecases" which is not
built by this project.
Call Stack (most recent call first):
src/libtools/tests/CMakeLists.txt:13 (target_link_elektratools)


-- Configuring incomplete, errors occurred!

All comments