Package Details: javafx-scenebuilder 16.0.0-0

Git Clone URL: https://aur.archlinux.org/javafx-scenebuilder.git (read-only, click to copy)
Package Base: javafx-scenebuilder
Description: Scene Builder is an open source tool that allows for drag and drop design of JavaFX user interfaces.
Upstream URL: https://gluonhq.com/products/scene-builder/
Keywords: Gluon javafx SceneBuilder
Licenses: BSD License
Submitter: moacirrf
Maintainer: moacirrf
Last Packager: moacirrf
Votes: 18
Popularity: 0.000012
First Submitted: 2016-11-21 09:56
Last Updated: 2021-03-28 03:14

Latest Comments

moacirrf commented on 2021-01-31 14:45

And i agree with you, i will drop 9,10,11,15 versions. thanks again.

moacirrf commented on 2021-01-31 14:33

Hi, nomisge Updated the version and description

Thanks.

nomisge commented on 2021-01-31 09:59

Since gluon only supplies two versions (https://gluonhq.com/products/scene-builder/) One for java8 and one for java11 and higher, I would only offer packages: javafx8-scenebuilder and javafx-scenebuilder (beeing the latest release). I would drop the other versions (9,10,11,15). (Also I submitted deletion requests for all out-of-date or orphaned versions not maintained by you).

I would adjust the description to the official one: "Scene Builder is an open source tool that allows for drag and drop design of JavaFX user interfaces."

The version and release date don't matter in the description, that's what version and upstream URL are for.

Please also update upstream URL, it is now: https://gluonhq.com/products/scene-builder/

And while your on it: There is a new version 15.0.1 (https://download2.gluonhq.com/scenebuilder/15.0.1/install/linux/SceneBuilder-15.0.1.deb)

Thanks.

moacirrf commented on 2020-12-18 11:18

I would like to turn this version on latest version 15, and drop the version 10 and turn this version javafx-scenebuilder-8. What you think?

Redrield commented on 2017-10-10 20:31

The top level `if` checking the value of CARCH can be replaced with source_x86_64 and source_i686, the sha1sums would be replaced with sha1sums_x86_64 and sha1sums_i686 respectively. That way, makepkg will sort out what to download and verify on its own.

moacirrf commented on 2017-10-04 13:37

spider-mario.

I will test and update with your patch as soon as possible.
Thank you.

spider-mario commented on 2017-10-03 19:51

Wouldn’t things be easier with the PKGBUILD written like this? https://ptpb.pw/qJrD.patch

This way, a simple `updpkgsums` would update all checksums correctly on package updates.

moacirrf commented on 2017-01-08 17:25

How to install:
1- Use command:

yaourt javafx-scenebuilder

2- Select only first package:

1 aur/javafx-scenebuilder 8.3.0-1 (4) (2,69)
Gluon Scene Builder based on debian package, this version is regognized by Netbeans.

moacirrf commented on 2016-11-21 11:43

If scene builder become slow or unresponsive etc...
Maybe is a problem with your Graphic Card driver.
You can disable Hardware Acceleration and use software pipeline instead.
1- As root, open:
/opt/SceneBuilder/app/SceneBuilder.cfg

2- Add this jvm option:
"-Dprism.order=sw" or "-Dprism.order=j2d"
j2d is deprecated, should not be used.

3- Complete example:
[Application]
app.name=SceneBuilder
app.mainjar=dist.jar
app.version=8.2.0
app.preferences.id=com/oracle/javafx/scenebuilder/app
app.mainclass=com/oracle/javafx/scenebuilder/app/SceneBuilderApp
app.classpath=
app.runtime=$APPDIR/runtime
app.identifier=com.oracle.javafx.scenebuilder.app

[JVMOptions]
-Dprism.order=sw
[JVMUserOptions]

[ArgOptions]