Package Details: jd-gui 1.4.0-4

Git Clone URL: (read-only)
Package Base: jd-gui
Description: A standalone graphical utility that displays Java source codes of .class files
Upstream URL:
Licenses: GPL3
Conflicts: jd-gui-bin
Provides: jd-gui
Submitter: simon04
Maintainer: simon04
Last Packager: simon04
Votes: 27
Popularity: 0.780654
First Submitted: 2015-05-27 20:51
Last Updated: 2017-11-13 21:21

Latest Comments

simon04 commented on 2017-12-10 19:50

The build fails with Java 7 due to the HTTPS config of

So you'd have to upgrade to Java 8, or edit ./gradle/wrapper/ and replace https with http (e.g. by executing sed -i s/https/http/ ./gradle/wrapper/

Koploseus commented on 2017-12-08 22:50

I have an error when installing this package, i get this :


Exception in thread "main" EC parameters error at at at at at at at at at at at org.gradle.wrapper.Download.downloadInternal( at at org.gradle.wrapper.Install$ at org.gradle.wrapper.Install$ at org.gradle.wrapper.ExclusiveFileAccessManager.access( at org.gradle.wrapper.Install.createDist( at org.gradle.wrapper.WrapperExecutor.execute( at org.gradle.wrapper.GradleWrapperMain.main( Caused by: EC parameters error at$P11ECPublicKey.getEncodedInternal( at at java.util.ArrayList.indexOf( at java.util.ArrayList.contains( at at at at at at at at at at at at ... 13 more Caused by: EC parameters error at at<init>( at$P11ECPublicKey.getEncodedInternal( ... 28 more Caused by: no such provider: SunEC at at at at at ... 30 more ==> ERREUR : Une erreur s’est produite dans build(). Abandon...</init>

For the moment, i used the jd-gui-bin

MarcinWieczorek commented on 2017-11-15 18:27

Please rename the tarball to ${pkgname}-${pkgrel}.tar.gz

simon04 commented on 2017-11-13 21:21

nahuelmorata, thanks a lot. I updated the PKGBUILD accordingly.

nahuelmorata commented on 2017-11-13 18:49

With this PKGBUILD ( i can compile jd-gui

crccw commented on 2016-02-12 12:51

Same "Could not find tools.jar" error with me. JAVA_HOME is set.
But you can use jd-gui-bin if you just want the binary

daurnimator commented on 2016-01-15 00:31

> Which JDK are you using?

$ pacman -Qs jdk
local/jdk7-openjdk 7.u91_2.6.3-3
OpenJDK Java 7 development kit
local/jre7-openjdk 7.u91_2.6.3-3
OpenJDK Java 7 full runtime environment
local/jre7-openjdk-headless 7.u91_2.6.3-3
OpenJDK Java 7 headless runtime environment
local/jre8-openjdk 8.u66-1
OpenJDK Java 8 full runtime environment
local/jre8-openjdk-headless 8.u66-1
OpenJDK Java 8 headless runtime environment

> Did you set JAVA_HOME?

No? what needs to be done?

simon04 commented on 2016-01-05 07:49

Which JDK are you using? Did you set JAVA_HOME? I assume it's some sort of misconfiguration.

daurnimator commented on 2016-01-05 02:55

Has been failing for me for a few months:

:distTar UP-TO-DATE
:distZip UP-TO-DATE
:doFirstDistTar UP-TO-DATE
:doFirstDistZip UP-TO-DATE
:compileJava UP-TO-DATE
:processResources UP-TO-DATE
:classes UP-TO-DATE
:api:compileJava FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':api:compileJava'.
> Could not find tools.jar

simon04 commented on 2015-12-01 12:21

@Kuci: I disagree, see
Also namcap does not require this dependency being added.

The_K commented on 2015-12-01 11:58

patch should be added as a make dependency.

Corax commented on 2015-11-24 22:15

Thanks for the fix, 1.4.0-2 builds fine. And good idea reporting upstream :)

simon04 commented on 2015-11-09 15:35

Thank you for reporting.

Build fixed in 1.4.0-2.

simon04 commented on 2015-11-09 15:28

I reported upstream:

Corax commented on 2015-11-09 13:14

Does not build with gradle 2.8 as one of the dependencies of jd-gui (Spock) depends on groovy 2.3.
Easy fix: in src/jd-gui-1.4.0/build.gradle, replace 'groovy-2.3' with 'groovy-2.4'.