Package Details: jdk5 5u22-1

Git Clone URL: https://aur.archlinux.org/jdk5.git (read-only)
Package Base: jdk5
Description: Oracle Java 5 Development Kit (public release - end of support)
Upstream URL: https://www.java.com/en/download/faq/java_5.xml
Licenses: custom
Provides: java-environment=5, java-environment-jdk=5, java-runtime=5, java-runtime-headless=5, java-runtime-headless-jre=5, java-runtime-jre=5, java-web-start=5, java-web-start-jre=5
Submitter: zaidan
Maintainer: zaidan
Last Packager: zaidan
Votes: 3
Popularity: 0.000111
First Submitted: 2016-01-18 20:24
Last Updated: 2017-06-27 16:45

Dependencies (17)

Required by (1000)

Sources (8)

Latest Comments

lonaowna commented on 2017-06-27 18:35

@zaidan, oh sorry, I didn't know that. Thanks anyway!

zaidan commented on 2017-06-27 16:53

@Ionaowna Sorry, I can only add a note. AUR does not support removing the URL and refuses my commit:

remote: error: missing source file: jdk-1_5_0_22-linux-i586.bin

lonaowna commented on 2017-06-21 13:23

@zaidan, can you remove the URLs from the PKGBUILD? Then it's clear that they have to be downloaded manually. Perhaps leave something like this:

# NOTE: please manually download these files from
# http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-javase5-419410.html
source_i686=("jdk-1_5_0_$_minor-linux-i586.bin")
source_x86_64=("jdk-1_5_0_$_minor-linux-amd64.bin")

zaidan commented on 2017-06-16 13:00

Oracle's otn-pub directory does not contain the files anymore.
You get a 404 with:
wget --no-cookies --no-check-certificate --header "Cookie: gpw_e24=http%3A%2F%2Fwww.oracle.com%2F; oraclelicense=accept-securebackup-cookie" http://download.oracle.com/otn-pub/java/jdk/1.5.0_22/jdk-1_5_0_22-linux-amd64.bin

When you try to download it from the official site you will get a redirect to the Oracle login page:
http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-javase5-419410.html

You have to create an account to get access to the download. The file
is downloadable after login.

This is not required for jdk8.

tata commented on 2017-06-14 17:19

jdk-1_5_0_22-linux-amd64.bin ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build jdk5.