Package Details: jdk8-openjdk-infinality 8.u152-1

Git Clone URL: (read-only)
Package Base: java8-openjdk
Description: OpenJDK Java 8 development kit with infinality patch applied
Upstream URL:
Keywords: fonts infinality java jdk jre
Licenses: custom
Conflicts: jdk8-openjdk
Provides: java-environment=8, java-environment-openjdk=8
Replaces: jdk8-openjdk-wm
Submitter: chrbayer
Maintainer: jkl
Last Packager: jkl
Votes: 31
Popularity: 0.995870
First Submitted: 2014-09-15 20:06
Last Updated: 2017-04-26 00:30

Required by (705)

Sources (10)

Latest Comments

Magotchi commented on 2018-03-16 14:52

I've made an updated source of this:

I took the official Arch pkgbase, added the Infinality patches, made it build with any java-environment 7 or higher (rather than only explicitly OpenJDK 7), removed the src and doc packages, and adjusted the package names and descriptions to match those of this pkgbase. Here's the diff from the official Arch PKGBUILD to mine:

It seems to work for me so far (although I pretty much only use this with IDEA). Feel free to update with my package if you want, jkl, or I can take over maintaining it, alternatively.

hugh commented on 2018-03-16 12:35

Is this package still maintained?

If so please update to 8u162, it contains important security patches.

Magotchi commented on 2018-03-12 17:07

It's back to the same problem brainplot was having on 2017-09-30, again.

Magotchi commented on 2017-10-02 17:32

I'm having the same problem as brainplot.

Edit: It did magically start working eventually. Probably a dependency issue.

brainplot commented on 2017-09-30 13:58

I've installed the package with pacaur and this is what I get every time I invoke any java command:

$ java -version
# A fatal error has been detected by the Java Runtime Environment:
# SIGSEGV (0xb) at pc=0x00007fd64eed033b, pid=18273, tid=0x00007fd62b559700
# JRE version: OpenJDK Runtime Environment (8.0_152-b03) (build 1.8.0_152-b03)
# Java VM: OpenJDK 64-Bit Server VM (25.152-b03 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# V []
# Core dump written. Default location: /home/gianluca/core or core.18273
# An error report file with more information is saved as:
# /home/gianluca/hs_err_pid18273.log
[thread 140557824653056 also had an error]
openjdk version "1.8.0_152"
OpenJDK Runtime Environment (build 1.8.0_152-b03)
OpenJDK 64-Bit Server VM (build 25.152-b03, mixed mode)

[error occurred during error reporting , id 0xb]

# If you would like to submit a bug report, please visit:
Aborted (core dumped)

It doesn't happen if I install any other jdk

jkl commented on 2017-09-13 17:53

@timofonic You will have to be more specific. I do not see the problem with the log posted.

timofonic commented on 2017-09-13 15:00

There's some wrong stuff there...

jilen commented on 2017-09-01 02:07

I've installed the package, but the font is actually unreadable for java application.

gim commented on 2017-08-08 14:26

pablo.doramas, you're right, it requires version 3.1.*. Not sure if it's safe to change it.

pablo.doramas commented on 2017-08-08 14:02

I have received the following output:

You have ccache installed, but it is a version prior to 3.1.4. Try upgrading.

but my ccache version is 3.3.4:

$ ccache --version | head -n 1
ccache version 3.3.4

problem seems to be in the 'grep' of the following line in:

36471 # Only use ccache if it is 3.1.4 or later, which supports
36472 # precompiled headers.
36475 HAS_GOOD_CCACHE=`($CCACHE --version | head -n 1 | grep -E 3.1.[456789]) 2> /dev/null`

All comments