Package Details: jed-snapshot 0.99.20.150-2

Git Clone URL: https://aur.archlinux.org/jed-snapshot.git (read-only, click to copy)
Package Base: jed-snapshot
Description: A freely available text editor - Latest development version
Upstream URL: http://www.jedsoft.org/snapshots/
Licenses: GPL
Conflicts: jed
Provides: jed
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 4
Popularity: 0.84
First Submitted: 2019-12-12 18:25
Last Updated: 2021-06-12 21:55

Latest Comments

1 2 Next › Last »

haawda commented on 2021-06-13 21:50

@prk21: fixed @csts: no, this is quite normal for a split package.

csts commented on 2021-06-12 22:52

This package is listed as rgrep 0.99.20.150-2. An error maybe?

prk21 commented on 2021-06-12 21:17

When I run makepkg, jed-snapshot fails to build due to the following missing dependencies: gpm, slang, and libxft.

If I manually install these dependencies, then makepkg succeeds.

I recommend adding a global depends= to your PKGBUILD file.

Excerpt from man PKGBUILD(5):

Note that makepkg does not consider split package depends when checking if dependencies are installed before package building and with --syncdeps. All packages required to make the package are required to be specified in the global depends and makedepends arrays.

Source: https://man.archlinux.org/man/PKGBUILD.5.en#PACKAGE_SPLITTING

kseistrup commented on 2020-03-25 13:03

Please add support for 'armv7h'.

haawda commented on 2019-12-25 22:10

Should be fixed in -3.

kseistrup commented on 2019-12-25 14:25

I get the following error while attempting to build 0.99.20.137-2:

==> Starting prepare()...
sed: can't read src/Makefile: No such file or directory
==> ERROR: A failure occurred in prepare().
    Aborting...

kseistrup commented on 2019-12-19 21:38

I cleared the whole thing and built from scratch, and now xjed is included. I should have done that from the beginning – I'm sorry for having wasted your time. I had built jed-git so many times before, I didn't expect anything to have gone wrong.

kseistrup commented on 2019-12-19 20:53

@haawda

Not in the package I built:

$ pacman --query --list jed-snapshot
jed-snapshot /usr/bin/
jed-snapshot /usr/bin/jed
jed-snapshot /usr/bin/jed-script
jed-snapshot /usr/bin/rgrep
$ pacman --query --owns /usr/bin/xjed
error: No package owns /usr/bin/xjed

So either something went wrong here, or the /usr/bin/xjed found on your box is a copy from a previous installation.

xjed is built alright, but not included in the package.

haawda commented on 2019-12-19 19:30

What do you mean? xjed is already included.

kseistrup commented on 2019-12-19 17:37

Would you care to include xjed in the package (optionally: create a separate package for xjed-snapshot, but that seems a little unresourceful)?