Package Details: jekyll 4.0.0-1

Git Clone URL: https://aur.archlinux.org/jekyll.git (read-only)
Package Base: jekyll
Description: A simple, blog aware, static site generator.
Upstream URL: https://github.com/jekyll/jekyll
Keywords: jekyll ruby
Licenses: MIT
Conflicts: ruby-jekyll
Provides: jekyll=4.0.0, ruby-jekyll
Replaces: ruby-jekyll
Submitter: SilverRainZ
Maintainer: SilverRainZ (bjo, bertptrs)
Last Packager: bertptrs
Votes: 74
Popularity: 1.137006
First Submitted: 2017-11-20 05:56
Last Updated: 2019-09-10 08:47

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 Next › Last »

anatolik commented on 2014-05-08 15:51

Yes, the problem is with ruby-celluloid package that pulls wrong dependencies. It should be reported there.

alexod commented on 2014-05-08 15:20

After upgrading I get the following error:

/usr/lib/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'timers' (~> 1.1.0) - did find: [timers-2.0.0] (Gem::LoadError)
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1295:in `block in activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1298:in `block in activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1298:in `block in activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_gem.rb:54:in `gem'
from /usr/bin/jekyll:22:in `<main>'

It seems that the wrong version of ruby-timers is in aur. Since the dependency on ruby-timer is indirect via ruby-celluloit, this is probably a bug in this package.

anatolik commented on 2013-12-16 07:17

btw I can take this and other your gems. I mostly scripted the gem->arch maintenance tasks.

anatolik commented on 2013-12-16 07:16

The "~>" version restriction does not map to Arch model directly. One needs to use "versioned packages"

https://wiki.archlinux.org/index.php/Ruby_Gem_Package_Guidelines#Versioned_packages

oliparcol commented on 2013-08-18 12:09

thank you, I will take a look

rberaldo commented on 2013-08-14 23:20

This might be of help: https://aur.archlinux.org/packages/pacgem/.

oliparcol commented on 2013-06-24 11:47

Hello,

Sorry for the delay. I'm open to suggestion but I don't know if it's really recommended to implement a bundle in a AUR package...

Do you have example of official archlinux ruby packages using a bundle (or a virtualenv for python) ?

thank you,

Muflone commented on 2013-06-24 11:42

This package unfortunately cannot work as long as it has so many external dependencies with specific versions.

I hope you could accept the suggest from artafinde.

artafinde commented on 2013-06-17 19:19

Can we make this use bundle as suggested on the bug:
https://github.com/plusjade/jekyll-bootstrap/issues/150

oliparcol commented on 2013-06-09 09:51

sorry for the delay, I just updated the package version to 1.0.3

and again, some AUR dependencies don't have the correct version