Package Details: jitsi-videobridge 2.1+478+gc6da57bd-1

Git Clone URL: https://aur.archlinux.org/jitsi-videobridge.git (read-only, click to copy)
Package Base: jitsi-videobridge
Description: Jitsi Meet Videobridge
Upstream URL: https://jitsi.org/jitsi-meet/
Licenses: Apache
Submitter: C0rn3j
Maintainer: celogeek
Last Packager: celogeek
Votes: 3
Popularity: 0.077062
First Submitted: 2020-03-14 12:01
Last Updated: 2021-04-17 09:34

Dependencies (6)

Required by (2)

Sources (6)

Pinned Comments

celogeek commented on 2021-04-10 08:31

Hi,

I have update the package to align to other jitsi-meet packages I maintain (stable, stable-bin, nightly, nightly-bin).

Now the package use Arch way for configs (/etc/jitsi-videobridge).

I made a blog post to configure jitsi-meet on arch. It use the -bin package, but now this one install files at the same places: https://blog.celogeek.com/posts/linux/archlinux/2020-06-jitsi-meet-on-arch-linux/

I'm working on alignment of all jitsi-meet packages. I will update the Arch Wiki as soon as I can.

Latest Comments

celogeek commented on 2021-04-10 08:31

Hi,

I have update the package to align to other jitsi-meet packages I maintain (stable, stable-bin, nightly, nightly-bin).

Now the package use Arch way for configs (/etc/jitsi-videobridge).

I made a blog post to configure jitsi-meet on arch. It use the -bin package, but now this one install files at the same places: https://blog.celogeek.com/posts/linux/archlinux/2020-06-jitsi-meet-on-arch-linux/

I'm working on alignment of all jitsi-meet packages. I will update the Arch Wiki as soon as I can.

Perdu commented on 2021-03-11 19:10

Current config file has a typo: double-quote at the end of line 22 should be removed or the file won't get parsed correctly

Perdu commented on 2021-02-22 20:01

Current version of this package has the following bug (following Arch Linux wiki basic installation): https://github.com/jitsi/jitsi-videobridge/issues/1547

Provided solution in the issue works. Add to your config:

VIDEOBRIDGE_GC_TYPE=G1GC

C0rn3j commented on 2020-11-03 09:02

I am not sure if this issue blocks you from running the JVB itself (my Jitsi instance is broken atm), but you can use jitsi-videobridge-git til a new release is tagged if it does.

SaltFactory commented on 2020-11-03 09:00

Hi, the latest release contains the following bug: https://github.com/jitsi/jitsi-videobridge/issues/1503

Because of this, I am unable to get the videobridge working. It has since been fixed in the following merge request: https://github.com/jitsi/jitsi-videobridge/pull/1507

However, it might take a while for the next stable release. Is there anything we can do in the meantime to fix this? Could we enable the statsCollector perhaps?

Thanks.

anarki commented on 2020-07-11 18:31

If you're running into crashes on users joining a room, put JVB_OPTS="--apis=xmpp," into jitsi-videobridge.conf

Reference https://community.jitsi.org/t/room-crashed-when-somebody-joined/21857

celogeek commented on 2020-05-27 00:19

Hi, can we follow more the debian upstream for this package?

  • The install directory should be there: /usr/share/jitsi-videobridge.
  • The service should be run as jvb:jitsi and not root!
  • The service should start with hardened permission.
  • You should have like the upstream those files in /etc/jitsi/videobridge: callstats-java-sdk.properties, config, log4j2.xml, sip-communicator.properties

I have made a standalone package here that does like the debian upstream:

https://github.com/celogeek/jitsi-meet-arch/blob/master/jitsi-videobridge/PKGBUILD

Eothred commented on 2020-05-07 05:27

Hi,

Thanks for maintaining this package. Minor thing, but to follow same structure as the -bin equivalent, the path to the config file would be:

/etc/jitsi/videobridge/config

C0rn3j commented on 2020-05-02 10:48

I updated the package to JVB2 - the config paths and format has changed.