Package Details: jogl 2.3.2-2

Git Clone URL: https://aur.archlinux.org/jogl.git (read-only)
Package Base: jogl
Description: OpenGL bindings for Java
Upstream URL: http://jogamp.org/
Licenses: BSD
Submitter: td123
Maintainer: MRWITEK
Last Packager: MRWITEK
Votes: 79
Popularity: 0.336110
First Submitted: 2011-12-07 20:36
Last Updated: 2016-02-07 20:46

Latest Comments

eolianoe commented on 2016-02-07 19:50

@bartus: it's buidling fine here. Maybe you have the new PKGBUILD with some old jar files ?

bartus commented on 2016-02-07 19:07

@MRWITEK It wont build even when skip outdated md5sums.
makepkg throws:
> find: `/jogl/src/natives': No such file or directory
> mv: missing file operand

MRWITEK commented on 2016-02-06 20:56

@bartus Yes they changed, but I've changed PKGBUILD accordingly, see changelog. The package should still contain 2 jars, 2 license files, several *.so files and simlinks.

bartus commented on 2016-02-06 19:42

Directory struct of orig jars has changed (native folder truncut). Package script not working.

Raimar commented on 2015-01-17 18:03

namcap wants 'java-environment' instead of 'java-runtime', also add 'libxrandr' and 'libxcursor' to dependency.

MRWITEK commented on 2014-09-09 20:13

Sorry, forgot to update checksums between 2.2.0 and 2.2.1 because when I've just done updating the package new version came out.

jdarch commented on 2014-09-09 19:24

Arer you sure the checksums are all right? I get checksum fails for the linked jogl-all.jar, gluegen-rt.jar, jogl-all-natives-linux-amd64.jar and gluegen-rt-natives-linux-amd64.jar.

jdarch commented on 2014-09-09 19:23

Arer you shure the checksums are all right? I get checksum fails for the linked jogl-all.jar, gluegen-rt.jar, jogl-all-natives-linux-amd64.jar and gluegen-rt-natives-linux-amd64.jar.

MRWITEK commented on 2014-07-12 13:21

http://jogamp.org/wiki/index.php/Downloading_and_installing_JOGL#Native_JARs_vs._native_library_files

nobody44, it's not like I forgot these jars, I just extract them and install native library files which are extracted by application anyway.

nobody44 commented on 2014-07-08 10:51

The package does not work without the gluegen-rt-natives-linux-amd64.jar and jogl-all-natives-linux-amd64.jar being copied to /usr/share/java/jogl/.

You added them as a source, but missed to install them in your package function.

MRWITEK commented on 2014-01-25 17:32

Hi electro, welcome to Arch community!

Personally, I'd send anything about changing the PKGBUILD to maintainer by email. Thanks for doing boring update! There is nothing special about it.

electro commented on 2014-01-25 16:57

Hi guys,

This is my first comment on the AUR!

I updated the PKGBUILD for 2.1.3 as per TomBoshoven's suggestion:
http://pastebin.com/1WKGwf67

I added a contributor field to include my name. Am I supposed to do this for a small edit like this, or are there different criteria for this?

Thanks.

TomBoshoven commented on 2014-01-02 01:33

Current stable version is 2.1.3 .

Updating is a matter of changing the pkgver and updating the MD5 sums.

nakednous commented on 2013-08-29 19:39

2.0.2 is out

MRWITEK commented on 2013-04-30 20:29

Now the package doesn't conflicts with libnewt.

MRWITEK commented on 2013-04-07 08:32

@mrbit, thanks!

mrbit commented on 2013-04-06 21:36

please add in the pkgbuild conflicts=( libnewt)
conflist, JOGL: / usr / lib / libnewt.so is already present in the filesystem

MRWITEK commented on 2012-12-14 16:28

Downgraded to xyproto's last PKGBUILD for now. It seems like he has left us a broken one.

nakednous commented on 2012-12-14 14:20

getting the same reported error as of today: install: can not stat of "jogl-*/lib/jogl.jar" File or directory does not exist

xyproto commented on 2012-12-14 10:59

Seems like jogl is now jogamp with friends.

xyproto commented on 2012-12-13 21:59

Someone should probably upload "jogamp" instead (and request that this package is deleted), it seems like they have changed a few things.

mrbit commented on 2012-12-13 19:11

install: can not stat of "jogl-*/lib/jogl.jar" File or directory does not exist

xyproto commented on 2012-12-11 18:56

MRWITEK, there's a dedicated button for notifying when a package is out of date: "Flag package out-of-date". Use it.

MRWITEK commented on 2012-12-11 16:38

How about updating to v2.0? I just can't builds scilab 5.4 because of it.

xyproto commented on 2012-07-19 10:01

strigyskow, updated the package, thanks for notifying

strigyskow commented on 2012-07-17 10:17

Hi,

could you please add the line

install -Dm644 jogl-*/lib/libjogl_cg.so "$pkgdir/usr/lib/"

to the package section? I was missing libjogl_cg.so dearly :). Not sure, if this needs nvidia-cg-toolkit as a dependency then, though.

strigyskow commented on 2012-07-17 08:44

Hi,

could you please add the line

install -Dm644 jogl-*/lib/libjogl_cg.so "$pkgdir/usr/lib/"

to the package section? I was missing libjogl_cg.so dearly :). Not sure, if this needs nvidia-cg-toolkit as a dependency then, though.

xyproto commented on 2011-12-08 20:39

Adopted the package and updated the PKGBUILD.

xyproto commented on 2011-12-08 20:39

Updated the PKGBUILD.

xyproto commented on 2011-12-08 20:31

Adopted package.