Package Details: joplin-beta 2.5.7-2

Git Clone URL: https://aur.archlinux.org/joplin-beta.git (read-only, click to copy)
Package Base: joplin-beta
Description: The latest pre-release - open source note taking and to-do application
Upstream URL: https://joplinapp.org
Keywords: joplin markdown note notetaking productivity todo
Licenses: MIT
Conflicts: joplin, joplin-desktop
Submitter: Alkindi
Maintainer: None
Last Packager: jingutech
Votes: 5
Popularity: 0.000641
First Submitted: 2020-10-04 21:35 (UTC)
Last Updated: 2021-11-04 12:29 (UTC)

Latest Comments

Qwinci commented on 2021-11-04 12:22 (UTC)

Please fix the PKGBUILD. (Change archlive to archive)

gyurman commented on 2021-09-27 19:06 (UTC)

arm64 termux proot arch

joplin-beta-2.4.4.tar.gz ... Passed ==> Removing existing $srcdir/ directory... rm: cannot remove '/home/gyurmo/.cache/yay/joplin-beta/src/joplin-2.4.4/packages/tools/node_modules/sqlite3/build/Release/node-addon-api/src': Directory not empty

maderios commented on 2021-06-03 10:07 (UTC)

It builds for me

==> Finished making: joplin-beta 2.0.4-1 (Thu 03 Jun 2021 11:53:04 AM CEST)
==> Installing package joplin-beta with pacman -U

zangoku commented on 2021-06-02 14:30 (UTC)

npm ERR! semver.simplifyRange is not a function

maderios commented on 2021-05-30 15:12 (UTC)

Today, it compiles successfully. Thanks.

maderios commented on 2021-05-22 07:30 (UTC)

I get errors:
lerna info lifecycle @joplin/app-clipper@1.0.8~postinstall: Failed to exec postinstall script lerna ERR! lifecycle "postinstall" errored in "@joplin/app-clipper", exiting 1 npm ERR! code 1 npm ERR! path /home/fre/ARCH-AUR/joplin-beta/src/joplin-2.0.2 npm ERR! command failed npm ERR! command sh -c npm run bootstrap --no-ci && npm run build npm ERR! A complete log of this run can be found in: npm ERR! /home/fre/.npm/_logs/2021-05-22T07_24_10_518Z-debug.log

maderios commented on 2021-05-18 09:35 (UTC)

Fail build: lerna ERR! npm install exited 1 in '@joplin/renderer'

nuc commented on 2021-05-18 03:33 (UTC) (edited on 2021-05-18 03:33 (UTC) by nuc)

My build is failing as well with the same issue as in the previous 3 comments.

This is failing for months already, I always omit updating joplin for that reason.

mascot26 commented on 2021-04-28 15:03 (UTC)

I'm still getting the same issue as the last two comments with the newest version. Anyone have any luck getting it to work?

vlas commented on 2021-03-30 10:50 (UTC) (edited on 2021-03-30 10:58 (UTC) by vlas)

Build error. Full yay output, 2021-03-30T10_54_12_010Z-debug.log

simona commented on 2021-03-30 08:38 (UTC)

npm ERR! code 1
npm ERR! path /home/simona/.cache/yay/joplin-beta/src/joplin-1.8.1
npm ERR! command failed
npm ERR! command sh -c npm run bootstrap --no-ci && npm run build

Alkindi commented on 2020-10-17 21:01 (UTC) (edited on 2020-10-17 21:01 (UTC) by Alkindi)

I had the same issue, for you information there is an open github issue: https://github.com/laurent22/joplin/issues/3584

To resolve this issue, go to /usr/share/joplin-cli and run sudo npm install immer.

I've updated the package and don't need to do it anymore.

Perfi commented on 2020-10-16 12:22 (UTC)

The CLI version currently breaks for me, with:

>>> joplin
internal/modules/cjs/loader.js:883
  throw err;
  ^

Error: Cannot find module 'immer'
Require stack:
- /usr/share/joplin-cli/lib/reducer.js
- /usr/share/joplin-cli/lib/BaseApplication.js
- /usr/share/joplin-cli/app.js
- /usr/share/joplin-cli/main.js
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:880:15)
    at Function.Module._load (internal/modules/cjs/loader.js:725:27)
    at Module.require (internal/modules/cjs/loader.js:952:19)
    at require (internal/modules/cjs/helpers.js:88:18)
    at Object.<anonymous> (/usr/share/joplin-cli/lib/reducer.js:4:17)
    at Module._compile (internal/modules/cjs/loader.js:1063:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1092:10)
    at Module.load (internal/modules/cjs/loader.js:928:32)
    at Function.Module._load (internal/modules/cjs/loader.js:769:14)
    at Module.require (internal/modules/cjs/loader.js:952:19) {
  code: 'MODULE_NOT_FOUND',
  requireStack: [
    '/usr/share/joplin-cli/lib/reducer.js',
    '/usr/share/joplin-cli/lib/BaseApplication.js',
    '/usr/share/joplin-cli/app.js',
    '/usr/share/joplin-cli/main.js'
  ]
}

Alkindi commented on 2020-10-11 15:41 (UTC)

Yes, I already did it.

juxuanu commented on 2020-10-11 14:04 (UTC)

Yes, please, remove what librewish mentioned. At the moment, having joplin installed and doing pacman -Syu makes it prompt asking for a replacement. "Do you want to replace "joplin" with "joplin-beta"?

librewish commented on 2020-10-11 12:14 (UTC) (edited on 2020-10-11 12:15 (UTC) by librewish)

Remove replaces=('joplin')

From pkgbuild