Package Details: jre21-jetbrains 21.0.2.b375.1-1

Git Clone URL: https://aur.archlinux.org/java21-jetbrains.git (read-only, click to copy)
Package Base: java21-jetbrains
Description: JetBrains Java 21 full runtime environment
Upstream URL: https://confluence.jetbrains.com/display/JBR/JetBrains+Runtime
Licenses: custom
Conflicts: jre21-jetbrains
Provides: java-runtime, java-runtime-jetbrains
Submitter: huyz
Maintainer: huyz
Last Packager: huyz
Votes: 1
Popularity: 0.000596
First Submitted: 2024-01-24 11:59 (UTC)
Last Updated: 2024-02-21 15:09 (UTC)

Required by (1521)

Sources (4)

Latest Comments

ingvij commented on 2024-03-21 06:40 (UTC)

I'm seeing [0.007s][warning][cds] This file is not the one used while building the shared archive file: /usr/lib/jvm/java-21-jetbrains/lib/modules whenever the this JDK gets executed... I looked into upstream and there's this that can be done in the build step maybe?

loathingkernel commented on 2024-02-03 22:31 (UTC)

The PKGBUILD needs !ccache in the options array otherwise the build process fails when ccache is enabled in makepkg.conf. This applies to java17-jetbrains too.

You do not need to add the package name in conflicts, it is added automatically by pacman

Ashark commented on 2023-10-28 20:07 (UTC) (edited on 2023-10-28 21:14 (UTC) by Ashark)

The url for jre package is outdated. Please link to the correct place: https://github.com/JetBrains/JetBrainsRuntime

Ashark commented on 2023-10-28 20:06 (UTC) (edited on 2023-10-28 21:14 (UTC) by Ashark)

The url for jre package is outdated. Please link to the correct place: https://github.com/JetBrains/JetBrainsRuntime

brsvh commented on 2022-10-24 03:31 (UTC)

It's fixed now, but I didn't test it in any JB IDEs.

dr460nf1r3 commented on 2022-10-23 11:10 (UTC)

Seems like the package needs an update? configure: Potential Boot JDK found at /usr/lib/jvm/java-17-openjdk is incorrect JDK version (openjdk version "17.0.5" 2022-10-18 OpenJDK Runtime Environment (build 17.0.5+1) OpenJDK 64-Bit Server VM (build 17.0.5+1, mixed mode)); ignoring configure: (Your Boot JDK version must be one of: 18 19) - full log here

brsvh commented on 2022-06-05 03:49 (UTC)

This package was initially intended to facilitate the use of the java11 version of Jetbrains Runtime.

I now plan to update it to version 17, by submitting a merge request to https://aur.archlinux.org/cgit/aur.git/?h=java-jbr-xdg.

I also created a java11 version of the package for backup and maintenance. https://aur.archlinux.org/cgit/aur.git/?h=java11-jbr-xdg

They use a unified name, replacing jetbrains-openjdk with jbr, which seems a bit more appropriate.