Package Details: jriver-media-center 26.0.94-1

Git Clone URL: https://aur.archlinux.org/jriver-media-center.git (read-only, click to copy)
Package Base: jriver-media-center
Description: The Most Comprehensive Media Software
Upstream URL: http://www.jriver.com/
Keywords: audio mediacenter video
Licenses: custom
Conflicts: jriver-media-center, jriver-media-center24
Submitter: blackhole
Maintainer: blackhole
Last Packager: blackhole
Votes: 10
Popularity: 0.030255
First Submitted: 2014-05-19 19:44
Last Updated: 2020-06-19 06:43

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

blackhole commented on 2015-09-04 07:17

Really I should have at least 3 versions...
1) version 20 32 bit
2) version 21 32 bit
3) version 21 64 bit

Personally I would like to stick to 21 at 64 bit.
I think that I could stick to version 20 for 32 bit and version 21 for 64 bit

If you need help for installing version 20, please write to
AudioLinux <audiolinux AT fastmail DOT fm>

mouseman commented on 2015-09-04 06:58

My Media Center 20 upgraded to 21 but I don't have a license for 21. Ideally, I wanted to stick to 20 until 21 becomes mainstream.

Both versions are getting new releases. 20 won't get any new features but it is still getting bugfixes and optimizations.

Are you able to split up the versions on AUR and keep them independent?

Thanks.

blackhole commented on 2015-08-18 12:08

See the windows 21 log for general non-linux related changes.

21.0.4 (8/14/2015)

1. Fixed: The "View Current Log" button on the logging dialog wasn't working.
2. Fixed: Exporting a playlist to HTML didn't open a browser to view the playlist properly.
3. Fixed: Viewing the html of a gallery in preview mode didn't open a browser properly to view the preview.
4. Changed: Internal, method of running an external command.
5. Fixed: Can purchase an upgrade via the usual method (install MC 20 license on MC 21 and follow the instructions).

21.0.3 (8/10/2015)

1. NEW: Improved font support.
2. Fixed: Trial period was broken.

21.0.2 (8/7/2015)

1. NEW: Subtitle Support during Video Playback.
2. Changed: Windows redraw better.
3. NEW: Image support. 2D viewing effects only at this time.

blackhole commented on 2015-07-25 09:52

New version 20.0.129 64 bit. Please test. This is the PKGBUILD

pkgname=jriver-media-center
_debpkgver=20.0.129
pkgver=$_debpkgver
pkgrel=1
pkgdesc="The Most Comprehensive Media Software"
arch=('x86_64')
url="http://www.jriver.com/"
license=('custom')
depends=('alsa-lib' 'gcc-libs' 'libx11' 'libxext' 'libxcb' 'libxau' 'libxdmcp' 'util-linux' 'libxext' 'gtk2' 'p11-kit' 'libtasn1' 'libgnutls26')
optdepends=('mesa-libgl: nouveau video support' 'nvidia-libgl: nvidia video support' 'xorg-fonts-75dpi:' 'xorg-fonts-100dpi:' 'vorbis-tools:' 'lame:' 'musepack-tools:')
source=("http://files.jriver.com/mediacenter/channels/v20/latest/MediaCenter-$pkgver-amd64.deb" 'License.txt')
sha256sums=('4b15a34b24992e3c28f05321eddba7fdfd900951628d2669a275072eeeeb2391' 'ee00f430918df6be37777a61e12812875b5583379c78daaa969bae7383a41fbd')

package() {
cd "$srcdir"
bsdtar xf data.tar.xz -C "$pkgdir"
install -Dm644 "License.txt" \
"$pkgdir/usr/share/licenses/$pkgname/COPYING"
}

blackhole commented on 2015-07-25 09:42

20.0.124 (7/13/2015)

1. Fixed: The focus fix from 20.0.123 was incomplete and was preventing the DSP studio (amongst others) from showing properly on hover.
2. Changed: All MC windows are class hinted properly now.

20.0.123 (6/23/2015)

1. Fixed: MC will no longer take focus from other apps on state transitions (unless MC has the mouse cursor).
2. Fixed: Ratings in the Purity Skin.

blackhole commented on 2015-06-22 21:59

20.0.122 (6/16/2015)

1. Changed: Changes from the main branch.

blackhole commented on 2015-06-11 06:44

20.0.114 (5/29/2015)

1. Changed: Changes from the main branch.

andrewchen commented on 2015-06-11 06:04

Hi, version 20.0.114 is out, please update.

blackhole commented on 2015-05-21 22:54

New version 20.0.111 64 bit. Please test. This is the PKGBUILD

pkgname=jriver-media-center
_debpkgver=20.0.111
pkgver=$_debpkgver
pkgrel=1
pkgdesc="The Most Comprehensive Media Software"
arch=('x86_64')
url="http://www.jriver.com/"
license=('custom')
depends=('alsa-lib' 'gcc-libs' 'libx11' 'libxext' 'libxcb' 'libxau' 'libxdmcp' 'util-linux' 'libxext' 'gtk2' 'p11-kit' 'libtasn1' 'libgnutls26')
optdepends=('mesa-libgl: nouveau video support' 'nvidia-libgl: nvidia video support' 'xorg-fonts-75dpi:' 'xorg-fonts-100dpi:' 'vorbis-tools:' 'lame:' 'musepack-tools:')
source=("http://files.jriver.com/mediacenter/channels/v20/latest/MediaCenter-$pkgver-amd64.deb")
sha256sums=('ce65d210c223f1e5e2c263e3f030c8043cc185358af77b91aa84a828bbb6eae1')

package() {
cd "$srcdir"
bsdtar xf data.tar.xz -C "$pkgdir"
}

blackhole commented on 2015-05-17 23:28

Now there is a 64 bit version

In Debian dependencies are
Depends: libc6 (>= 2.19), libasound2 (>= 1.0.27), libuuid1 (>= 2.20), libx11-6 (>= 2:1.6), libxext6 (>= 2:1.3), libxcb1 (>= 1.10), libxdmcp6 (>= 1:1.1), libstdc++6, libgtk2.0-0 (>= 2.24), libp11-kit0 (>= 0.20), libtasn1-6, libgnutls-deb0-28 | libgnutls28, libgcrypt20 (>= 1.6), libidn11 (>= 1.28), libgl1-mesa-glx | libgl1, xdg-utils, exo-utils | kde-runtime | konqueror | gvfs-bin | libgnome2-0 | pcmanfm, xfonts-75dpi, xfonts-100dpi, xfonts-unifont
Recommends: lame (>= 3.99), vorbis-tools (>= 1.4.0), musepack-tools

In my new PKGBUILD I have
depends=('alsa-lib' 'gcc-libs' 'libx11' 'libxext' 'libxcb' 'libxau' 'libxdmcp' 'util-linux' 'libxext' 'gtk2' 'p11-kit' 'libtasn1' 'libgnutls26')
optdepends=('mesa-libgl: nouveau video support' 'nvidia-libgl: nvidia video support' 'xorg-fonts-75dpi:' 'xorg-fonts-100dpi:' 'vorbis-tools:' 'lame:' 'musepack-tools:')

However I am not finding equivalent for some packages, for example libgnutls28
xfonts-unifont etc.

If someone has some idea...(now I have a segmentation error)