Package Details: jsonpipe-git 20110412-1

Git Clone URL: https://aur.archlinux.org/jsonpipe-git.git (read-only)
Package Base: jsonpipe-git
Description: Convert JSON to a UNIX-friendly line-based format.
Upstream URL: https://github.com/zacharyvoase/jsonpipe
Licenses: custom
Submitter: mikesd
Maintainer: mikesd
Last Packager: mikesd
Votes: 2
Popularity: 0.000000
First Submitted: 2011-04-12 11:34
Last Updated: 2015-06-21 10:17

Required by (0)

Sources (0)

Latest Comments

mikesd commented on 2013-10-13 12:18

You need python2-calabash. calabash is an unrelated package. It wouldn't run without the python2-argparse package. Will look into this but it at least works now.

kvasthval commented on 2013-10-09 15:16

I have the same issue, mvisser.
Also, python-simplejson is now called python2-simplejson, python2-argparse is not needed anymore as it is integrated in Python v2.7 and the version change using sed is also no longer needed.
Oh, and the repository is now residing at https://github.com/zacharyvoase/jsonpipe instead of https://github.com/dvxhouse/jsonpipe.

Anonymous comment on 2011-07-19 01:33

It seems some dependencies are not listed in the PKGBUILD... I couldn't get it to work after installing calabash either, since the AUR version is a higher version.

Traceback (most recent call last):
File "/usr/bin/jsonpipe", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2709, in <module>
working_set.require(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 686, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 584, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: calabash==0.0.3