Package Details: jupyterlab-git 1:3.0.0rc10.r27.g71a6d8416-1

Git Clone URL: https://aur.archlinux.org/jupyterlab-git.git (read-only, click to copy)
Package Base: jupyterlab-git
Description: JupyterLab computational environment
Upstream URL: https://github.com/jupyterlab/jupyterlab
Keywords: jupyter notebook python
Licenses: custom
Submitter: fabianz
Maintainer: fusion809
Last Packager: fusion809
Votes: 4
Popularity: 0.012750
First Submitted: 2016-07-31 22:21
Last Updated: 2020-11-20 16:59

Pinned Comments

fusion809 commented on 2020-07-07 12:09

In case anyone is wondering, yes I am well aware that there is a build error at the moment, but a bug report for it exists upstream https://github.com/jupyterlab/jupyterlab/issues/8657, and there's nothing I can do about it downstream until they fix it upstream.

Latest Comments

« First ‹ Previous 1 2 3

fabianz commented on 2016-10-20 11:28

I just rebuilt from master, everything is working fine for me. Running 'jupyter lab' gives me (among others) the following log line:

[I 13:10:22.796 LabApp] The Jupyter Notebook is running at: http://localhost:8888/

It opens my default browser (Firefox) with the given url and JupyterLab is usable without issues.

First thought: Do you run some other HTTP server on port 8888?
If that's not the case, could you run 'jupyter lab --debug' and upload the output (using e.g. some pastebin service), giving a link to it here. That may help investigating.

Regarding the usage of pip: I like to keep everything managed by pacman - pip is essentially a different package manager and using it without a python venv may leave you with files untracked by pacman, potentially leading to package problems. See also https://bbs.archlinux.org/viewtopic.php?id=139264

juliohm commented on 2016-10-20 05:35

When I try to launch JupyterLab with "jupyter lab" in the command line, I get a new tab in Chrome with:

404 : Not Found
You are requesting a page that does not exist!

Could you please confirm this is an issue of the master branch? Would it be safe to install the lab with pip?