Package Details: jzip 2.1-10

Git Clone URL: https://aur.archlinux.org/jzip.git (read-only)
Package Base: jzip
Description: Jzip is an interpreter for games in the Infocom Zcode story file format
Upstream URL: http://jzip.sourceforge.net/
Licenses: custom
Submitter: darose
Maintainer: darose
Last Packager: darose
Votes: 33
Popularity: 0.000242
First Submitted: 2005-04-12 04:27
Last Updated: 2016-12-15 18:53

Latest Comments

benutzer193 commented on 2016-12-16 08:36

@darose: you are welcome, thanks for the quick update!

darose commented on 2016-12-15 18:54

Whoops - sorry for the oversight. Thanks for pointing out! Fixed.

noplomplom commented on 2016-12-15 18:25

@darose: You also have to change $startdir/src to $srcdir at line 19.

darose commented on 2016-12-15 15:33

Updated. Thanks for the suggestion @benutzer193

benutzer193 commented on 2016-12-15 12:54

You could change $startdir/src to $srcdir to allow alternate builddir.
(That fixes the problem noplomplom encountered.

noplomplom commented on 2016-12-13 05:50

Ok, I found and solved the issue: it didn't work because I'm building my packages in tmp. I just commented the following line in my /etc/makepkg.conf:

BUILDDIR=/tmp/makepkg

and it worked.

darose commented on 2016-12-12 15:31

It works for me either way - from downloading the snapshot or from git clone:

snapshot:
* download snapshot jzip.tar.gz
$ tar -xvzf jzip.tar.gz
$ cd jzip
$ makepkg

git:
$ git clone https://aur.archlinux.org/jzip.git
$ cd jzip
$ makepkg


I get:

==> Extracting sources...
-> Extracting jzip21-10oct2000.zip with bsdtar
==> Starting build()...
patching file Makefile
gcc -O2 -DPOSIX -DHAVE_GETOPT -DHARD_COLORS -D_FORTIFY_SOURCE=2 -c -o jzip.o jzip.c

...

==> Finished making: jzip 2.1-8 (Mon Dec 12 10:24:19 EST 2016)


I really have no idea what your issue could be. Are you having this problem when you build other packages from AUR? Anything unique about your setup? Is anyone else having the same issue?

noplomplom commented on 2016-12-10 08:03

I downloaded the snapshot and it didn't work. Am I supposed to clone the git repo then? Is there a difference?

Here's the error I get when running makepkg in the unzipped snapshot folder:

==> Extracting sources...
-> Extracting jzip21-10oct2000.zip with bsdtar
==> Starting build()...
/home/dom/Downloads/jzip/PKGBUILD: line 19: cd: /home/dom/Downloads/jzip/src: No such file or directory
==> ERROR: A failure occurred in build().
Aborting...

darose commented on 2016-12-07 19:37

Odd - works for me. I just did a fresh git clone and makepkg, and received no errors.

noplomplom commented on 2016-12-07 19:24

Can't build the package, get an error on line 19 (folder does not exist).

All comments