Package Details: k380-function-keys-conf 1.1-1

Git Clone URL: https://aur.archlinux.org/k380-function-keys-conf.git (read-only, click to copy)
Package Base: k380-function-keys-conf
Description: Make function keys on Logitech K380 bluetooth keyboard default
Upstream URL: https://github.com/jergusg/k380-function-keys-conf
Licenses: GPL
Submitter: nclsprsn
Maintainer: None
Last Packager: nclsprsn
Votes: 3
Popularity: 0.139029
First Submitted: 2020-05-30 15:17 (UTC)
Last Updated: 2020-05-30 15:17 (UTC)

Latest Comments

fermino commented on 2024-04-15 22:12 (UTC)

@torpe23 I know, I was just wondering just because I read of some strange interactions between ZFS and systemd in its bug tracker. I will look into it and see if I can find something.

torpe23 commented on 2024-04-15 19:53 (UTC)

@fermino no I'm not using ZFS. As @nclsprsn said, the issue is probably in the udev rule.

fermino commented on 2024-04-15 01:27 (UTC)

@torpe23 are you by any change also using ZFS?

nclsprsn commented on 2024-04-14 08:23 (UTC)

Hi, I will not be able to help unfortunately I don't own the K380 keyboard anymore to perform the test.

@torpe23, it must be related to the udev rule somehow.

ijann commented on 2024-04-13 13:09 (UTC) (edited on 2024-04-13 13:10 (UTC) by ijann)

==> Making package: k380-function-keys-conf 1.1-1 (sáb 13 abr 2024 10:02:38)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting build()...
gcc k380_conf.c -o k380_conf
==> Entering fakeroot environment...
==> Starting package()...
install: cannot stat '../../80-k380.rules': No such file or directory
==> ERROR: A failure occurred in package().
    Aborting...
error: failed to build 'k380-function-keys-conf-1.1-1': 
error: packages failed to build: k380-function-keys-conf-1.1-1
PAKtC

torpe23 commented on 2024-04-12 19:17 (UTC)

Hi there, after many years of working fine, the udev rule doesn't seem to be properly triggered when I pair my K380 keyboard. I need to run fn_on.sh as root regularly. Not sure how to debug. I noticed that the /dev/hidraw* nodes are not dynamically added when the keyboard is paired, but I don't know if it's the expected behavior. Any assistance would be appreciated!

ijann commented on 2024-04-11 20:48 (UTC)

Because in the afternoon, change the use of the keyboard and I have to use the FN key. :/