Package Details: kag 0.91A-2

Git Clone URL: https://aur.archlinux.org/kag.git (read-only)
Package Base: kag
Description: King Arthur's Gold Classic is a game about building castles and destroying your enemies (inspired by Soldat and Minecraft)
Upstream URL: http://kag2d.com/
Keywords: game strategy
Licenses: custom
Conflicts: kag
Submitter: reflexing
Maintainer: aaronfischer
Last Packager: aaronfischer
Votes: 28
Popularity: 0.002598
First Submitted: 2011-07-23 07:05
Last Updated: 2015-06-13 19:51

Latest Comments

luuuciano commented on 2016-04-26 01:57

So... how can we use this without sudo kag? there is no way?

aaronfischer commented on 2014-05-06 21:22

I've updated the package and fixed severval issues mentioned here (permission problems, libpng1.5 dependency), changed the download location and add the correct version. WARNING: This is King Arthurs Gold CLASSIC version, not the current beta version!

dustball commented on 2013-04-22 14:57

Could you please update the package? Thanks a lot :)

CaioAlonso commented on 2012-11-08 19:27

Today when opening the game just a portion of the servers showed up on the server list. One of them had the name "NEW VERSION AT KAG2D.COM UPDATE MANUALLY".

Then, I attempted to download the latest tar.gz from kag2d.com and it seems that the game's autoupdate feature is not working to update it to the latest version (569).

So maybe it is necessary to update this package to the new version.

vaviary commented on 2012-11-05 16:13

I can't run the game as a normal user.
It starts the launcher just fine, but as soon as I click on "play" it just closes the window. Terminal says the following:
"rungame.sh: line 5: 2211 Segmentation fault ./KAG autostart Scripts/autostart.gm autoconfig Scripts/autoconfig.gm"
It runs just fine with "sudo kag". Any idea how to fix this? Thanks.

Anonymous comment on 2012-10-03 09:37

This package has been updated to 469-3
> Tweaked PKGBUILD

Anonymous comment on 2012-10-03 09:23

This package has been updated to 469-2
> Tweaked kag.install script

Anonymous comment on 2012-10-03 09:07

@kyrylo, adopted, thanks!
This package has been updated to build 469.

kyrylo commented on 2012-10-03 08:54

I disowned it.

Anonymous comment on 2012-10-03 08:44

@kyrylo, sure, I'm up for it.

kyrylo commented on 2012-10-03 08:40

Nice! @chrassidy, do you want to adopt this package?

Anonymous comment on 2012-10-03 07:45

I've uploaded the patched PKGBUILD and kag.install scripts (Working as of 10/2/12, build 469).
PKGBUILD - http://sprunge.us/DSIU (Added dependencies needed to run the game properly, updated md5sum, updated cp command)
kag.install - http://sprunge.us/Whii (Modified post install script to fix permissions, and added post_remove script to remove leftover directories)

sakalisc commented on 2012-09-24 10:15

Hello. Source validation of the "kag_x.tar.gz" file fails for me. Perhaps it was updated upstream?

Anonymous comment on 2012-09-21 05:09

Boom roasted.

kyrylo commented on 2012-08-19 15:54

Adopting back, because the package was in an orphan state all this time.

kyrylo commented on 2012-08-07 13:43

@Barthalion, first of all, I'm not the guy who wrote the PKGBUILD, I just maintain it. Secondly, it works for me and I'm fine with it (and for other fellows, by the way). Thirdly, it's not *my* job, OK? You don't pay me money, so, please, be a tad more adult in your derisory judgements. Fourthly, the game auto updates itself, so the version number isn't really crucial.

You know what? I'm not your rival, so I'll just disown this package and give you a great chance to demonstrate your outstanding PKGBUILD writing skills.

Barthalion commented on 2012-08-06 13:04

Of course you should know that current build is 469, but who cares.

Barthalion commented on 2012-08-06 13:01

Yes, seriously. Is debugging foreign to you?
* wrong arch -- c'mon, "any" for ELF files?
* wrong md5sums
* directory name has been changed to kag-linux32
* lack of lib32-libxxf86vm and lib32-freetype2 in deps for x86_64 users
* lack of hicolor-icon-theme for all users
* 2 useless "install" commands

So now when I did your job at least go and fix the package.

kyrylo commented on 2012-08-06 09:52

@Barthalion, "broken"? Seriously? That's how trusted users describe the problem? Just "broken", right? Leastwise, you could have mentioned what doesn't work for you, because it works here just fine.

Barthalion commented on 2012-08-06 09:36

Your PKGBUILD is broken and ugly. Make it work, follow Arch Packaging Standards, use namcap and test if it builds in chroot using devtools. Or just orphan.

kyrylo commented on 2012-07-14 19:55

How so? Can someone confirm that?

hickop commented on 2012-07-14 19:50

lib32-libxxf86vm required as x86_64 depends.

kyrylo commented on 2012-05-18 15:01

% packer -S lib32-libstdc++5
Package `lib32-libstdc++5' does not exist.
% packer -S lib32-freetype2
Package `lib32-freetype2' does not exist.

disastro commented on 2012-05-15 17:55

64-bit dependencies should most likely include lib32-freetype2 and lib32-libstdc++5 because when I downloaded the game manually, not from the PKGBUILD I couldn't run the game without those libraries, freh install today

kyrylo commented on 2012-04-15 16:21

@gururise, thank you. PKGBUILD updated.

gururise commented on 2012-04-15 15:29

Download link has changed to: http://kag2d.com/en/download/kag_x.tar.gz

Anonymous comment on 2012-04-08 15:12

For the sound, i also had to install lib32-alsa-plugins

kyrylo commented on 2012-04-05 18:31

The latest update of the game has broken my game. Currently, I can't even launch it for some reason:

`rungame.sh: line 5: ./KAG: cannot execute binary file`

kyrylo commented on 2012-04-05 18:20

The latest update of the game has broken my game. Currently, I can't even launch it for some reason:

`rungame.sh: line 5: ./KAG: cannot execute binary file`

kyrylo commented on 2012-03-27 19:38

@Manifolded, your proposition isn't good. How shall I differentiate, which user has what graphics card? So, nVidia users would have to install ATI drivers? Or manually edit PKGBUILD on the fly, retaining only needed driver?

With respect to "[@]}" oddity: I don't know, why is so. I'm not the author of these lines of code of PKGBUILD, but check out Arch Wiki: https://wiki.archlinux.org/index.php/PKGBUILD#arch

I don't want to touch it yet. Let's wait for another game's build, and I'll try to fix it.

Anonymous comment on 2012-03-27 19:18

So you should probably have those packages as dependencies then.. And is there something wrong the libgl dependency we have here? libgl [@]} <--- what is the funny at symbol?

Anonymous comment on 2012-03-27 19:14

For people with 64 bit systems who are suffering from segfaults like archdia, please install the lib32 packages corresponding to your graphics card:

lib32-nouveau-dri
lib32-nvidia-utils
lib32-ati-dri

Anonymous comment on 2012-03-21 15:57

new md5sum for kag_x.tar.gz is e0c5913da0cfdac5d27d496e8ce1c8d4

Anonymous comment on 2012-03-03 00:58

inegrity check error i had to force skip it

kyrylo commented on 2012-01-21 21:28

@archdria, it sounds like a problem with the game, not with the package. It works for me, leastwise.

archdria commented on 2012-01-21 20:20

I installed version 274 and does not run:
$ kag
Running KAG
mv: cannot stat `KAG.tmp': No such file or directory
chmod: changing permissions of `KAG': Operation not permitted
PID: 8163
Starting in directory: /usr/share/kag
Changed directory to: /usr/share/kag/
Engine (build: 273 version: 0.95A)
Creating video device...
Irrlicht Engine version 1.8.0-alpha
Linux 3.2.1-1-ARCH #1 SMP PREEMPT Fri Jan 13 06:50:31 CET 2012 x86_64
Using renderer: OpenGL 2.1
Gallium 0.4 on llvmpipe: VMware, Inc.
OpenGL driver version is 1.2 or better.
GLSL version: 1.2
rungame.sh: line 5: 8163 Segmentation fault ./KAG autostart Scripts/autostart.gm autoconfig Scripts/autoconfig.gm

reflexing commented on 2011-12-26 05:38

@prostosuper please, adopt it

kyrylo commented on 2011-12-25 11:19

Sorry, I've wanted to own it (because I play the game) ever since I wrote my message, but, unfortunately, I completely forgot about this package (it's hard to keep track of messages in here).

reflexing commented on 2011-12-07 03:10

@prostosuper well, I disowned it, so what? Not adopted, nothing. Why did you ask?
Adopted back, updated.

kyrylo commented on 2011-12-04 13:58

reflexing, please, disown it.

Anonymous comment on 2011-09-20 06:43

md5sum for kag151x.tar.gz is '1fc2ee8ac74e29d4976729963c3297f6'

reflexing commented on 2011-09-20 05:14

I'm on vacation now, will apdate ASAP as I get home. Before you can simply change version in PKGBUILD yourself. I don't play the game actually and made this package just for fun. If somebody wants to maintain it for good I can disown it. Thanks and sorry for delay.

dgellow commented on 2011-09-17 10:42

And please, update the package link:
http://kag2d.com/download/file/kag151x.tar.gz

dgellow commented on 2011-09-17 10:40

Can you add lib32-libxxf86vm as dependence ?

reflexing commented on 2011-09-05 05:19

@Huulivoide: i've searched ABS about this and found many official packages with binaries and 'any' architecture. I think it's more a matter of taste.

Huulivoide commented on 2011-09-03 14:11

This isint by anymeans a 'any' package
'any' arch pkgs only contain non binary
executables (scripts, icons, themes....).

please use
if [ "$CARCH" == "x86_64" ]
depends=('lib32-gcc-libs' 'lib32-libgl')
fi