Package Details: kakoune-git 2022.10.31-1

Git Clone URL: (read-only, click to copy)
Package Base: kakoune-git
Description: Multiple-selection, UNIX-flavored modal editor
Upstream URL:
Keywords: editor kakoune multiple-selection unix
Licenses: custom:UNLICENSE
Conflicts: kakoune
Provides: kakoune
Submitter: galaux
Maintainer: lenormf
Last Packager: lenormf
Votes: 39
Popularity: 0.000000
First Submitted: 2013-12-18 16:01 (UTC)
Last Updated: 2023-03-03 12:01 (UTC)

Dependencies (11)

Required by (17)

Sources (1)

Latest Comments

1 2 3 4 5 6 Next › Last »

lenormf commented on 2021-07-23 05:01 (UTC)

Thanks for reminding me! I've modified the manifest and tweaked it further (dependencies, optional dependencies, cosmetics etc.).

swiftscythe commented on 2021-07-22 12:22 (UTC)

If I understand it correctly, the ncurses dependency is no longer needed, right?

lenormf commented on 2020-12-09 09:19 (UTC)

Thank you, the package manifest has been modified. I've also verified that it worked with kak-snippets-git.

Ordoviz commented on 2020-12-08 07:05 (UTC)

@lenormf I tried it and can confirm that pacman treats 2020.09.01_r192_g411bf736 >= 2019.07.01 as true.

lenormf commented on 2020-12-07 07:52 (UTC)

Ordoviz, the version number for kakoune-git has a different format, are you sure kak-snippets-git is going to resolve 2020.01.16_r186_g60154300 as 2020.01.16?

Ordoviz commented on 2020-11-14 09:47 (UTC)

Consider replacing provides=('kakoune') with provides=("kakoune=$pkgver"). On install I got the error: “removing kakoune breaks dependency 'kakoune>=2019.07.01' required by kak-snippets-git”

lenormf commented on 2020-01-27 07:00 (UTC)

Trying cleaning the cache of whatever AUR package manager you're using.

hisacro commented on 2020-01-26 18:56 (UTC)

/bin/ld: .commands.opt.o: file not recognized: file truncated collect2: error: ld returned 1 exit status make: *** [Makefile:108: kak.opt] Error 1 ==> ERROR: A failure occurred in build(). Aborting...

not sure why I'm getting this error

maximbaz commented on 2019-01-22 07:04 (UTC)

The wiki doesn't say the base-devel package has to be installed fully:

This is a fair argument :) There was also another line "Note: Packages in the AUR assume that the base-devel group is installed, i.e. they do not list the group's members as dependencies explicitly.", but I agree it wasn't quite clear.

To be consistent all the way down, I adapted the wiki to say "Ensure the base-devel package group is installed in full".

lenormf commented on 2019-01-22 06:53 (UTC)

The wiki doesn't say the base-devel package has to be installed fully:

Ensure the base-devel package group is installed

But since the PKGBUILD does expect users to have gcc installed, which is part of this package group and is not listed in the PKGBUILD, I'm removing pkgconf from the build dependencies in the name of consistency.

Note that neither cat nor uname are necessary to build the project ;)