Package Details: kamaki 0.13-3

Git Clone URL: https://aur.archlinux.org/kamaki.git (read-only)
Package Base: kamaki
Description: A command-line tool for managing clouds
Upstream URL: http://code.grnet.gr/projects/kamaki
Licenses: BSD
Submitter: axil42
Maintainer: axil42
Last Packager: axil42
Votes: 2
Popularity: 0.000000
First Submitted: 2013-01-20 20:18
Last Updated: 2015-06-10 06:15

Dependencies (7)

Required by (1)

Sources (2)

Latest Comments

axil42 commented on 2015-01-11 12:05

Moved to depends array, thanks :)

skalkoto commented on 2015-01-11 10:36

Hello,

astakosclient is a real dependency not just a build dependency.

axil42 commented on 2014-12-26 09:04

Added in makedepends :)

joko commented on 2014-12-23 20:58

`astakosclient` package is required to build kamaki docs.

Could you please add astakosclient as a dependency? Thanks in advance.

axil42 commented on 2014-12-10 20:14

Cool, thanks :)

I used the debian patch. Also added python2-dateutil as an extra dep.

skalkoto commented on 2014-12-10 19:10

kamaki 0.13 is out:
https://pypi.python.org/packages/source/k/kamaki/kamaki-0.13.tar.gz

The big difference from the previous versions is that it works over https, so it needs certificate. The place where the CA certifications file is found is distro specific. For Arch Linux like Debian, the path is this:
/etc/ssl/certs/ca-certificates.crt

In the package you need to patch the default.py file to add this. Take a look at the debian patch:
https://github.com/grnet/kamaki/blob/debian-wheezy/debian/patches/deb-defaults.patch

skalkoto commented on 2013-10-17 09:52

kamak 0.11.1 is out:

https://pypi.python.org/packages/source/k/kamaki/kamaki-0.11.1.tar.gz

axil42 commented on 2013-07-28 18:23

You're right! Removed from deps, thanks :)

skalkoto commented on 2013-07-28 11:15

Hello,

I don't think argparse is needed as a dependency. This python module is present in python standard library since version 2.7. It still exists as a backport for older versions of python. Since archlinux uses version 2.7 of python2, this package is completely useless. No wonder it has been orphaned.

axil42 commented on 2013-07-27 08:31

Hey skalkoto, thanks for the heads up! Would it make your life easier if you adopted these packages? I don't mind updating these, but since you are the upstream developer it would make more sense to maintain these.

All comments