Package Details: kanatest 0.4.10-10

Git Clone URL: https://aur.archlinux.org/kanatest.git (read-only)
Package Base: kanatest
Description: A simple Hiragana and Katakana drill tool
Upstream URL: http://www.clayo.org/kanatest/
Licenses: GPL
Submitter: angvp
Maintainer: balwierz (mtasaka)
Last Packager: balwierz
Votes: 30
Popularity: 1.400054
First Submitted: 2008-09-08 00:40
Last Updated: 2017-11-08 15:01

Dependencies (5)

Required by (0)

Sources (1)

Latest Comments

balwierz commented on 2017-11-08 15:04

Thank you Mamoru,
I made these modifications and it works well. However, adding -Werror-implicit-function-declaration would cause compile-time errors.

Version numbering reverted to version instead of git date/commit, because of project inactivity.

mtasaka commented on 2017-11-07 14:00

> I got it to work with SF git, but at least on my system it crashes.

I am not Arch Linux user, however if you
* see some warnings on build log like
```
gui.c:813:20: warning: implicit declaration of function 'gdk_pixbuf_new_from_inline'; did you mean 'gdk_pixbuf_new_from_file'? [-Wimplicit-function-declaration]
gui.c:813:18: warning: assignment makes pointer from integer without a cast [-Wint-conversion]
stock_icons.c:58:18: warning: implicit declaration of function 'gdk_pixbuf_new_from_inline'; did you mean 'gdk_pixbuf_new_from_file'? [-Wimplicit-function-declaration]
stock_icons.c:58:16: warning: assignment makes pointer from integer without a cast [-Wint-conversion]
```
* see crash like below
```
(gdb) bt
#0 0x00007ffff7861423 in IA__gtk_icon_source_set_pixbuf (source=0x5555558213d0, pixbuf=0x55817e40) at gtkiconfactory.c:2057
#1 0x000055555556a05a in kanatest_register_stock_icons () at stock_icons.c:60
#2 0x000055555555fabc in gui_create_window (appGUI=0x5555557a9690) at gui.c:776
#3 0x000055555555c40b in main (argc=<optimized out>, argv=<optimized out>) at main.c:136
```

Then you are probably seeing the same issue as:
https://bugzilla.redhat.com/show_bug.cgi?id=1296655
and similar fix like
https://src.fedoraproject.org/rpms/kanatest/c/3a76dbe3944679e8d450fc380b831dff25c1e49a?branch=master
is needed.

(Due to missing function prototype, compiler assumes the return value is int although the actual return type is pointer,
so on 64bit system, 32bit information is lost and afterwards invalid address is to be read)

balwierz commented on 2017-11-06 19:52

Thanks Popolon. I got it to work with SF git, but at least on my system it crashes. Can you check if it crashes for you too, so I can report it upstream?

Popolon commented on 2017-11-04 22:42

The svn.gna.org doesn't exist anymore. After the sf site, the source is now hosted here :

https://sourceforge.net/p/kanatest/code/ci/master/tree/

Tensor commented on 2016-10-16 14:50

In order to get the katakana statistics to work you have to change two lines in the function "test_update_answer_stats" before compiling.

appGUI->sts->katakana_counters[kana_number]++;
->
appGUI->sts->katakana_counters[kana_number-MIXED_SEPARATOR]++;

and

appGUI->sts->correct_katakana_counters[kana_number]++;
->
appGUI->sts->correct_katakana_counters[kana_number-MIXED_SEPARATOR]++;

felix.s commented on 2016-06-06 22:03

You should use source=(kanatest::svn+http://...#revision=88) instead of invoking svn co directly.

p90 commented on 2016-05-29 10:31

Here is the complete output:

http://pastebin.com/rxKA7M0p

p90 commented on 2016-05-25 14:41

Hi,

cannot build this anymore:

make[2]: Für das Ziel „install-exec-am“ ist nichts zu tun.
for i in de.mo el.mo es.mo fi.mo fr.mo hu.mo it.mo pl.mo pt.mo ru.mo zh_CN.mo; do \
lang=`echo $i | sed 's/\.mo$//'`; \
/bin/sh /tmp/yaourt-tmp-p91/aur-kanatest/src/build/install-sh -d /tmp/yaourt-tmp-p91/aur-kanatest/pkg/kanatest/usr/share/locale/$lang/LC_MESSAGES; \
/usr/bin/install -c -m 644 $i /tmp/yaourt-tmp-p91/aur-kanatest/pkg/kanatest/usr/share/locale/$lang/LC_MESSAGES/kanatest.mo; \
done
/usr/bin/install: der Aufruf von stat für 'de.mo' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
/usr/bin/install: der Aufruf von stat für 'el.mo' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
/usr/bin/install: der Aufruf von stat für 'es.mo' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
/usr/bin/install: der Aufruf von stat für 'fi.mo' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
/usr/bin/install: der Aufruf von stat für 'fr.mo' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
/usr/bin/install: der Aufruf von stat für 'hu.mo' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
/usr/bin/install: der Aufruf von stat für 'it.mo' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
/usr/bin/install: der Aufruf von stat für 'pl.mo' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
/usr/bin/install: der Aufruf von stat für 'pt.mo' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
/usr/bin/install: der Aufruf von stat für 'ru.mo' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
/usr/bin/install: der Aufruf von stat für 'zh_CN.mo' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
Makefile:452: die Regel für Ziel „install-data-local“ scheiterte
make[2]: *** [install-data-local] Fehler 1
make[2]: Verzeichnis „/tmp/yaourt-tmp-p91/aur-kanatest/src/build/po“ wird verlassen
Makefile:331: die Regel für Ziel „install-am“ scheiterte
make[1]: *** [install-am] Fehler 2
make[1]: Verzeichnis „/tmp/yaourt-tmp-p91/aur-kanatest/src/build/po“ wird verlassen
Makefile:398: die Regel für Ziel „install-recursive“ scheiterte
make: *** [install-recursive] Fehler 1

awh commented on 2014-12-20 22:36

Needs to depend on svn.

p90 commented on 2014-09-25 13:00

Found a solution.
I apparently have to run "aclocal" before I try to compile this package.
No idea why but it works now.

p90 commented on 2014-09-24 06:38

I think this is missing some dependencies at build time.
It failed at first because I did not have svn and automake installed (which was easy to fix but still should be in the pkg file in the first place)
and now fails with:

checking which GTK+ version to compile against... 2.0
./configure: line 3886: syntax error near unexpected token `GTK,'
./configure: line 3886: `PKG_CHECK_MODULES(GTK, gtk+-$GTK_API_VERSION >= $GTK_REQUIRED)'

So my guess is I am missing the right GTK files for this?

balwierz commented on 2014-06-13 21:32

Adopted; removed unused .desktop file; updated to rev 88

fmang commented on 2013-09-14 12:38

Also, srcdir seems to be undefined from the global scope. You should move the definition of _builddir into build().

fmang commented on 2013-09-14 12:33

Got it to build by updating _rev to 86 (version 0.4.10) and removing -Werror at configure.ac:6.

tsester commented on 2013-01-26 19:14

this is WRONG : i copied Makefile.in from "kanatest-0.4.8" from folders : "src" and "po" and it compiles fine. it plays too

skydark commented on 2012-10-22 15:09

my PKGBUILD(depends on ubuntu's ppa): http://pastebin.com/3Ws1TSj4

KaiSforza commented on 2012-09-06 03:58

Not to sound like this pkgbuild is worse than the ones I've put out, but it's pretty bad. and this package shouldn't be `kanatest`, it should be `kanatest-svn`. Getting a lot of errors when building it too.

https://gist.github.com/3650428

Anonymous comment on 2011-05-16 15:10

@adaptee: Thanks, fixed.

adaptee commented on 2011-05-16 14:41

`yaourt -Syu` kept reinstalling this package. Would you please check its version naming scheme ?