Package Details: kathara 3.7.4-1

Git Clone URL: https://aur.archlinux.org/kathara.git (read-only, click to copy)
Package Base: kathara
Description: A lightweight container-based network emulation tool.
Upstream URL: https://www.kathara.org/
Keywords: docker kubernetes network-emulation nfv
Licenses: GPL3
Submitter: skazza94
Maintainer: skazza94 (5amu, tcaiazzi)
Last Packager: tcaiazzi
Votes: 3
Popularity: 0.004025
First Submitted: 2021-02-18 10:45 (UTC)
Last Updated: 2024-03-27 16:36 (UTC)

Dependencies (8)

Required by (0)

Sources (1)

Latest Comments

tcaiazzi commented on 2023-05-29 08:50 (UTC)

Sorry for the late reply!

We updated the package to the latest version (3.6.0) and we added the missing dependencies.

awel commented on 2023-04-07 14:45 (UTC) (edited on 2023-04-07 14:45 (UTC) by awel)

Could you add python as a dependency? I just tried installing this package on a freshly installed Arch Linux ARM and looks like python is not installed by default. Cheers!

tcaiazzi commented on 2022-09-29 14:31 (UTC)

I added the patchelf dependency. Thanks for notice it!

famar commented on 2022-09-29 13:48 (UTC)

Thanks. A new required dependency is needed to build: patchelf

tcaiazzi commented on 2022-09-29 09:55 (UTC) (edited on 2022-09-29 09:55 (UTC) by tcaiazzi)

Hi all, with the new release (3.5.1) we resolved the issue with Python3.10.

Sorry for the inconvenience.

famar commented on 2022-06-07 11:24 (UTC)

The issue still persists.

famar commented on 2021-12-26 11:19 (UTC)

I confirm the issue of @wh75er on finding a too specific version of pip.

wh75er commented on 2021-12-25 17:26 (UTC) (edited on 2021-12-25 18:08 (UTC) by wh75er)

I'm not sure if it's relevant to package outdating, but build fails on prepare phase because of incorrect python version

==> Starting prepare()...
.cache/yay/kathara/PKGBUILD: line 20: .cache/yay/kathara/src/venv/bin/pip3.9: No such file or directory

I have python3.10 and pip3.10 in my system, maybe just only use major version:

$srcdir/venv/bin/pip3

instead of hardcoded minor version:

$srcdir/venv/bin/pip3.9

?

UPD.

It didn't help. Looks like pyuv package is broken and not compatible with python3.10

I'm getting error on setup.py install pyuv

https://github.com/saghul/pyuv/issues/271

project is unmaintaned right now